There are plans to support Windows environment?

I've just installed mojito module in windows environment (node 0.6.12) and  when I execute tests by

> mojito test
I got the following error
error: (nodejsyui3): ----------------------------------------------------------error: (nodejsyui3): Error: Cannot find module 'C:..\glob.js'error: (nodejsyui3):  at Function._resolveFilename (module.js:332:11)error: (nodejsyui3):  at Function._load (module.js:279:25)error: (nodejsyui3):  at Module.require (module.js:354:17)error: (nodejsyui3):  at require (module.js:370:17)error: (nodejsyui3):  at [object Function].require (C:\Users\aschiavo\AppData\Roaming\npm\node_modules\mojito\node_modules\yui3\lib\node-yui3.js:514:16)error: (nodejsyui3):  at C:\Users\aschiavo\AppData\Roaming\npm\node_modules\mojito\lib\tests\autoload\glob-tests.js:1:373error: (nodejsyui3):  at Object.fn (C:\Users\aschiavo\AppData\Roaming\npm\node_modules\mojito\lib\tests\autoload\glob-tests.js:9:16)

4 Replies
  • Mojito currently requires the yui3 package, which is only available on Linux and Mac. It ships YUI 3.4.X for nodejs. However, there are yui 3.5 packages that can be installed on Windows systems:

    I did not test Mojito with those, but it might be worth a shot. I don't have a Windows system at hand, where I could try it.
  • Note that there are a number of issues with executing Mojito on the Windows platform. We will be working through these as we update the public release.

  • PR1103 was merged yesterday, and v0.6.0 will be released in about 3 days with support for windows: https://github.com/yahoo/mojito/pull/1103


Recent Posts

in Yahoo! Mojito