Node 0.8.0

I just setup a new environment with node 0.8.0 and I couldn't install mojito through npm. Is it incompatible? if not, can I force it to load through npm? If I can't do that I may need some advice on running multiple versions of node.

2 Replies
  • We haven't tested Mojito with 0.8.0, so we currently can't provide support for that.  In mojito's package.json it is restricting itself to node >= 0.4.0 and < 0.7.0.  If you want to try mojito on node 0.8.0 you'll need to download the mojito source and edit the package.json before installing.

    I use nvm to manage multiple node versions.  I set that up a while ago, and I think there are newer solutions out there.  Search the net for "node.js multiple versions" and I think you'll find a lot of discussion.

  • I've tested mojito with node 0.8. After replacing exists and existsSync in mojito and yui it fails one test (i don't remember which). So in general it works (i've tried, and my test code works).

Recent Posts

in Yahoo! Mojito