0

Error installing shaker

Hi, I'm not sure if I should post it here, but I've got a problem with installing shaker.

First I installed Mojito global (version 0.4.3). Mojito test works fine.
The I installed Shaker global (version 2.0.9), which seems ok at first glance.

But according to the installation, the command: mojito-shake should go without errors.
On my systems (I tried it on 2 different virtual machines), I get next error: 

=========================================================
/usr/lib/nodejs/mojito-shaker/node_modules/yui/yui-nodejs/yui-nodejs.js:1147
            throw (e || new Error(msg));
                        ^
Error: Cannot find module 'ycb'
=========================================================

Can anyone tell me what goes wrong (and how to make it work)?

Thx,
Marco Asbreuk

by
2 Replies
  • It seems that you are missing the YCB module:
    https://npmjs.org/package/ycb

    Did its installation fail?
    0
  • Hi Fabian,

    That did the trick, thx.
    I don't know if it should have been installed automaticly during installation of Mojito, or Shaker, but it didn't. And shakers getting-started instructions don't mention the installation of ycb.

    I've got it working now.

    Regards,
    Marco.


    QUOTE(Fabian Frank @ 8 Sep 2012 2:07 PM)
    It seems that you are missing the YCB module:
    https://npmjs.org/package/ycb

    Did its installation fail?

    0

Recent Posts

in Yahoo! Mojito