0

SaveRawMessage appending body text to header text..

Hi folks,

I'm able to call SaveRawMessage without any errors, but the message body isn't showing up as expected.. The body lines are appended to the header lines.

Starting with this:

CODE
From: "Some Sender" <some.sender@senderdomain.com>
To: someone@somewhere.com
Subject: Subject goes here
Date: 17 Sep 2010 23:56:12 -0400
Reply-To: some.sender@senderdomain.com
Message-ID: <A098BC1E87A61D498CAD12DF2FA63894@senderdomain.com>
MIME-version: 1.0
Content-type: text/plain

First line of the body
Second line

Fourth line


Seventh line


I'm sending these params:
CODE
[{"fid":"Inbox","text":"RnJvbTogIlNvbWUgU2VuZGVyIiA8c29tZS5zZW5kZXJAc2VuZGVyZG9tYWluLmNvbT4NClRvOiBz
b21lb25lQHNvbWV3aGVyZS5jb20NClN1YmplY3Q6IFN1YmplY3QgZ29lcyBoZXJlDQpEYXRlOiAxNyBTZ
XAgMjAxMCAyMzo1NjoxMiAtMDQwMA0KUmVwbHktVG86IHNvbWUuc2VuZGVyQHNlbmRlcmRvbWFpbi5jb2
0NCk1lc3NhZ2UtSUQ6IDxBMDk4QkMxRTg3QTYxRDQ5OENBRDEyREYyRkE2Mzg5NEBzZW5kZXJkb21haW4
uY29tPg0KTUlNRS12ZXJzaW9uOiAxLjANCkNvbnRlbnQtdHlwZTogdGV4dC9wbGFpbg0KDQpGaXJzdCBs
aW5lIG9mIHRoZSBib2R5DQpTZWNvbmQgbGluZQ0KDQpGb3VydGggbGluZQ0KDQoNClNldmVudGggbGluZ
Q0K"}]

And ending up with this (when I click "View Full Header"):
CODE
From Some Sender Fri Sep 17 20:56:12 2010
Received: from [70.63.156.156] by mail.yahooapis.com via HTTP; Fri, 24 Sep 2010 01:28:26 UTC
From: "Some Sender" <some.sender@senderdomain.com>
To: someone@somewhere.com
Subject: Subject goes here
Date: 17 Sep 2010 23:56:12 -0400
Reply-To: some.sender@senderdomain.com
Message-ID: <A098BC1E87A61D498CAD12DF2FA63894@senderdomain.com>
MIME-version: 1.0
Content-type: text/plain
First line of the body
Second line
Fourth line
Seventh line
Content-Length: 0


What am I missing?

by
0 Replies
  • Hi,

    The request doesn't look to be a problem here but just to make sure can you confirm that you are doing a base64_encode of the text msg?
    I guess the problem can happen if the MIME injected is not as per RFC standards. Can you confirm if you mime is constructed fine? Thanks.

    --R

    QUOTE (Eli Holder @ Sep 23 2010, 06:08 PM) <{POST_SNAPBACK}>
    Hi folks,

    I'm able to call SaveRawMessage without any errors, but the message body isn't showing up as expected.. The body lines are appended to the header lines.

    Starting with this:

    CODE
    From: "Some Sender" <some.sender@senderdomain.com>
    To: someone@somewhere.com
    Subject: Subject goes here
    Date: 17 Sep 2010 23:56:12 -0400
    Reply-To: some.sender@senderdomain.com
    Message-ID: <A098BC1E87A61D498CAD12DF2FA63894@senderdomain.com>
    MIME-version: 1.0
    Content-type: text/plain

    First line of the body
    Second line

    Fourth line


    Seventh line


    I'm sending these params:
    CODE
    [{"fid":"Inbox","text":"RnJvbTogIlNvbWUgU2VuZGVyIiA8c29tZS5zZW5kZXJAc2VuZGVyZG9tYWluLmNvbT4NClRvOiBz
    b21lb25lQHNvbWV3aGVyZS5jb20NClN1YmplY3Q6IFN1YmplY3QgZ29lcyBoZXJlDQpEYXRlOiAxNyBT
    Z
    XAgMjAxMCAyMzo1NjoxMiAtMDQwMA0KUmVwbHktVG86IHNvbWUuc2VuZGVyQHNlbmRlcmRvbWFpbi5jb
    2
    0NCk1lc3NhZ2UtSUQ6IDxBMDk4QkMxRTg3QTYxRDQ5OENBRDEyREYyRkE2Mzg5NEBzZW5kZXJkb21haW
    4
    uY29tPg0KTUlNRS12ZXJzaW9uOiAxLjANCkNvbnRlbnQtdHlwZTogdGV4dC9wbGFpbg0KDQpGaXJzdCB
    s
    aW5lIG9mIHRoZSBib2R5DQpTZWNvbmQgbGluZQ0KDQpGb3VydGggbGluZQ0KDQoNClNldmVudGggbGlu
    Z
    Q0K"}]

    And ending up with this (when I click "View Full Header"):
    CODE
    From Some Sender Fri Sep 17 20:56:12 2010
    Received: from [70.63.156.156] by mail.yahooapis.com via HTTP; Fri, 24 Sep 2010 01:28:26 UTC
    From: "Some Sender" <some.sender@senderdomain.com>
    To: someone@somewhere.com
    Subject: Subject goes here
    Date: 17 Sep 2010 23:56:12 -0400
    Reply-To: some.sender@senderdomain.com
    Message-ID: <A098BC1E87A61D498CAD12DF2FA63894@senderdomain.com>
    MIME-version: 1.0
    Content-type: text/plain
    First line of the body
    Second line
    Fourth line
    Seventh line
    Content-Length: 0


    What am I missing?
    0

Recent Posts

in Yahoo! Mail Web Services API