0

result count = 0

hi guys i have a problem.

i made this request:

var sam = y.rest(url3).get().response;
response.object = sam;

with url3 = "http://dblp.uni-trier.de/rec/bibtex/conf/sigmod/GuptaDG08.xml". but incredibly the count is 0, no result. i have put this log: y.log(sam) and i have received this:

<log>&lt;dblp&gt; &lt;inproceedings key="conf/edbt/BarbieriBCG10" mdate="2010-03-18"&gt; &lt;author&gt;Davide Francesco Barbieri&lt;/author&gt; &lt;author&gt;Daniele Braga&lt;/author&gt; &lt;author&gt;Stefano Ceri&lt;/author&gt; &lt;author&gt;Michael Grossniklaus&lt;/author&gt; &lt;title&gt;An execution environment for C-SPARQL queries.&lt;/title&gt; &lt;pages&gt;441-452&lt;/pages&gt; &lt;year&gt;2010&lt;/year&gt; &lt;booktitle&gt;EDBT&lt;/booktitle&gt; &lt;ee&gt;http://doi.acm.org/10.1145/1739041.1739095&lt;/ee&gt; &lt;crossref&gt;conf/edbt/2010&lt;/crossref&gt; &lt;url&gt;db/conf/edbt/edbt2010.html#BarbieriBCG10&lt;/url&gt; &lt;/inproceedings&gt; &lt;/dblp&gt;</log>

that is the exact structure of my xml. so i'm sure that i receive it, but why it doesn't appear in the result of my query???

by
1 Reply
  • QUOTE (Samuele @ Apr 18 2010, 07:13 AM) <{POST_SNAPBACK}>
    hi guys i have a problem.

    i made this request:

    var sam = y.rest(url3).get().response;
    response.object = sam;

    with url3 = "http://dblp.uni-trier.de/rec/bibtex/conf/sigmod/GuptaDG08.xml". but incredibly the count is 0, no result. i have put this log: y.log(sam) and i have received this:

    <log>&lt;dblp&gt; &lt;inproceedings key="conf/edbt/BarbieriBCG10" mdate="2010-03-18"&gt; &lt;author&gt;Davide Francesco Barbieri&lt;/author&gt; &lt;author&gt;Daniele Braga&lt;/author&gt; &lt;author&gt;Stefano Ceri&lt;/author&gt; &lt;author&gt;Michael Grossniklaus&lt;/author&gt; &lt;title&gt;An execution environment for C-SPARQL queries.&lt;/title&gt; &lt;pages&gt;441-452&lt;/pages&gt; &lt;year&gt;2010&lt;/year&gt; &lt;booktitle&gt;EDBT&lt;/booktitle&gt; &lt;ee&gt;http://doi.acm.org/10.1145/1739041.1739095&lt;/ee&gt; &lt;crossref&gt;conf/edbt/2010&lt;/crossref&gt; &lt;url&gt;db/conf/edbt/edbt2010.html#BarbieriBCG10&lt;/url&gt; &lt;/inproceedings&gt; &lt;/dblp&gt;</log>

    that is the exact structure of my xml. so i'm sure that i receive it, but why it doesn't appear in the result of my query???


    Please can you provide a link to your table definition and the query you are running.

    The two usual causes of not seeing any output when you appear to have content are
    (1) An itemPath in the table that doesnt exist in the return structure
    (2) Applying a local filter in the WHERE clause that doesn't exist / can't match

    Jonathan
    0

Recent Posts

in YQL