YQL rest call returning Access Forbidden while it is working perfect in yql-console

Need Help! Below query is working fine in yql console, but failing with rest call a few days back it was working perfect http://query.yahooapis.com/v1/public/yql?q=select%20*%20from%20xml%20where%20url%3D'http%3A%2F%2Frss.imdb.com%2Fdaily%2Fborn%2F'&diagnostics=true error returned :---

"http://www.yahooapis.com/v1/base.rng" <yahoo:count=>"1" <yahoo:created=>"2013-09-11T08:30:42Z" <yahoo:lang=>"en-US"> true 98 96 0.2.1805 403 Access denied

2 Replies
  • I'm experiencing the same issue while trying to request 'select * from html where url="<http://www.xroxy.com/proxylist.php?type=transparent&country=UA&sort=latency>"' (corresponding rest query). The weird thing is: first time I spotted it (around a week ago) - issue disappeared after about an hour or two. Now it's back. Can it be somehow related to the YQL (v1/public) usage limits (quotas)?

    Right now aforementioned REST query returns: xml <query <xmlns:yahoo=>"<http://www.yahooapis.com/v1/base.rng>" <yahoo:count=>"0" <yahoo:created=>"2013-11-10T17:51:21Z" <yahoo:lang=>"en-US"> <diagnostics> <publiclyCallable>true</publiclyCallable> <url error="Redirected to a robots.txt restricted URL: <http://www.xroxy.com/proxylist.php?type=transparent&country=UA&sort=latency>" execution-start-time="1" execution-stop-time="3" execution-time="2" http-status-code="403" http-status-message="Forbidden"> <![CDATA[ <http://www.xroxy.com/proxylist.php?type=transparent&country=UA&sort=latency> ]]> </url> <user-time>3</user-time> <service-time>2</service-time> <build-version>0.2.1997</build-version> </diagnostics> <results/> </query>

    Thank you.

  • An update: REST query mentioned in previous reply started to return data.


Recent Posts

in YQL