2

YQL Yahoo Finance - Query Failing

Hello, For the last week or so, when I run the following query "select * from yahoo.finance.quotes where symbol = 'CLN14.NYM'" using the YQL console, or my custom app, the results returned indicate " No such ticker symbol. <a href=/l>Try Symbol Lookup</a> (Look up: <a href=/l?s=CLN14.NYM>CLN14.NYM</a>) "...

What's weird is that this just started happening. It's been working fine for months. The ticker symbol IS valid. If you lookup the quote using the web UI, "http://finance.yahoo.com/q?s=CLN14.NYM", it works fine.

Normal stock quotes seem to be working, but commodity quotes seem to be failing (I'm looking up 2 - CLN14.NYM and BZN14.NYM - both same results).

Anyone have an idea what's going on?

Thanks in advance, Simon.

by
2 Replies
  • I'm seeing the same problem. I'm using the crude oil ticker as well, along with natural gas. Not sure what to do, but if I find a solution, I'll note it here.

    0
  • BTW an NON-Technical... came here looking for some ideas of the problem

    Tried SImons link, Chart Not Available, then selected show one day only, and the chart appeared.

    Tried change to AIO.AX the failing popup appeared, while the chart appeared OK underneath.

    Many users of Yahoo Finance portfolios experiencing similar problems, within their portfolio pages, though for self mostly within the ASX ( eg BHP.AX .)

    Self experiences similar problem, ON/OFF, even on different computers.

    Yahoo Charts Portfolio Detailed custom views sometimes NOT show preferred chart period expected view.

    Sometimes changes periods shown NOT what sort, other times says no historical data available. bookmarked URL's helped self realize this may happen..

    Similar with holdings when see these stocks trading on other software.

    Is NOT clear why these changes occur, data supply problem?

    Does this happen more where newer (easier to use when get data) charts are being sort for use ?

    Will the newer style charts fail with dates set within URL's when use a non-trading date ?

    0

Recent Posts

in YQL