XML table on google spreadsheet table feed - no data returned - no error


I want to use the XML open table to fetch data from a Google Spreadsheet table feed.

Here's the feed, returning the data as atom XML:


this is my query:

select * from xml where url="https://spreadsheets.google.com/feeds/cells/0Au659FdpCliwdG44Q2htMWJEQUxVQ3NfRlZUdlZaalE/od6/private/full"

In the returned data, the result section is empty, there are no error messages, and the correct URL is mentioned:
<url execution-time="176" proxy="DEFAULT"><![CDATA[https://spreadsheets.google.com/feeds/cells/0Au659FdpCliwdG44Q2htMWJEQUxVQ3NfRlZUdlZaalE/od6/private/full]]></url>

I also tried to run the query on http://developer.yahoo.com (thus: http:// i.o. https://), same result.

Note: my final goal is to be able to query the Google spreadsheet like a database table. Using the Google access methods out-of-box, you can fetch
- either individuals cells, but based on a query referencing column and row indices (i.e. 'A', 'B', ... '1', '2', ...)
- either using a query referencing column names, but then you receive the data of the complete row in a single string (e.g. "en:christmas, fr:noel"), so then you must parse this string
Based on the complete cell-based worksheet contents, YQL XML open table should be able to fetch the right data based on some clever XPath expression.


5 Replies

Recent Posts

in YQL