0

Weird Problem with YQL, probably encoding problem

Hello,

I have a problem with YQL that's rather weird to me and hope you can help me. First of all, I'd like to say that it worked over years in the past but stopped working now.

So I want to get transportation departure times.

It works perfectly with this query using station "Petuelring":

<http://query.yahooapis.com/v1/public/yql?format=json&q=select> content from html where url="<http://www.mvg-live.de/ims/dfiStaticAnzeige.svc?haltestelle=Petuelring>" and xpath="//td[contains(@class,'Column')]/p"

this query refers to the URL http://www.mvg-live.de/ims/dfiStaticAnzeige.svc?haltestelle=Petuelring

However it doesn't work with this query using station "Poccistra├če":

<http://query.yahooapis.com/v1/public/yql?format=json&q=select%20content%20from%20html%20where%20url=%22http>://<http://www.mvg-live.de/ims/dfiStaticAnzeige.svc?haltestelle=Poccistra%DFe%22%20and%20xpath=%22//td>[contains%<28@class>,%27Column%27%29]/p%22

or (what I typed in):

<http://query.yahooapis.com/v1/public/yql?format=json&q=select> content from html where url="<http://www.mvg-live.de/ims/dfiStaticAnzeige.svc?haltestelle=Poccistra%DFe>" and xpath="//td[contains(@class,'Column')]/p"

referring to http://www.mvg-live.de/ims/dfiStaticAnzeige.svc?haltestelle=Poccistra%DFe

So my problem is both links work in the same way but the query gives results for stations that don't need encoding but doesn't for those stations that need encoding (I use ISO 8859-1) As it worked in the past and the resulting URLs don't seem to have changed I assume that the reason is to find in the query language. Have there been changes in the past and do you know proper solutions to solve this problem?

Thank you very much

by
1 Reply

Recent Posts

in YQL