0

Table XML Parse Error Cannot find the declaration of element

I'm getting an error after running a YQL query on a .gov xml file

Here's the query:

USE 'http://www.reginfo.gov/public/do/XMLViewFileAction?f=EO_RULES_UNDER_REVIEW.xml' AS reg_records; Select * from reg_records;

The YQL console gives me this error message:

Table XML Parse Error for reg_records [line 5:22 cvc-elt.1: Cannot find the declaration of element 'OIRA_DATA'.]

Is this a problem with my query or is it perhaps a problem with the source XML file?

Any help would be appreciated.

JV

by
1 Reply
  • Hi, I think you want to use this query:<br><br>select * from xml where url = &quot;http://www.reginfo.gov/public/do/XMLViewFileAction?f=EO_RULES_UNDER_REVIEW.xml&quot;<br><br>Thanks -Paul<br>YQL Team<br><br><br><div class="quote "><div class="quotetop ">QUOTE<cite>(anonymous @ 21 Nov 2011 6:39 AM)</cite><blockquote class="quotemain">I&#39;m getting an error after running a YQL query on a .gov xml file<br><br>Here&#39;s the query:<br><br>USE &#39;http://www.reginfo.gov/public/do/XMLViewFileAction?f=EO_RULES_UNDER_REVIEW.xml&#39; AS reg_records; Select * from reg_records;<br><br>The YQL console gives me this error message:<br><br>Table XML Parse Error for reg_records [line 5:22 cvc-elt.1: Cannot find the declaration of element &#39;OIRA_DATA&#39;.]<br><br>Is this a problem with my query or is it perhaps a problem with the source XML file?<br><br>Any help would be appreciated.<br><br>JV</blockquote></div></div>
    0

Recent Posts

in YQL