3

Possible BUG: YQL query timing out / memcached problem at Yahoo?

When I execute the following YQL REST query

http://bit.ly/1cpWCBu

(URL shortened because it is rather long)

It takes way too long to execute and return with a response (> 20 seconds).

This behaviour is showing since ca. 1 week. Before, the same query only took < 3 seconds.

I switched the diagnostics switch to on.

The diagnostics output seems to indicate that some memcached instances are failing / timing out - here is a snippet of the diagnostics output:

<query execution-start-time="31" execution-stop-time="34" execution-time="3">
select * from csv where
url='<http://download.finance.yahoo.com/d/quotes.csv?s=EURGBP=X&f=snl1d1t1ab>'
and
columns='Symbol,Name,Rate,Date,Time,Ask,Bid'
</query>
<javascript execution-start-time="30"
execution-stop-time="34"
execution-time="4"
instructions-used="130694"
table-name="yahoo.finance.xchange"/>
<cache error="Timed out waiting for operation -
failing node: memcache ext1.yql.bf1.yahoo.com/98.139.238.131:11211"
execution-start-time="6"
execution-stop-time="2506"
execution-time="2500"
method="GET"
type="MEMCACHED">bd3f70eab1f14327d209b5e6a99691cb
</cache>

curiously, if I execute the same query in the YQL console, it returns very fast!

Here is a screenshot of the diagnostics output returned by Yahoo:

http://screencast.com/t/kpzDr6arCx

The full YQL query:

select * from yahoo.finance.xchange where pair in ("USDMXN", "EUREUR","EURAED","EURARS","EURAUD","EURBSD","EURBHD","EURBDT","EURBZD","EURBOB","EURBRL","EURGBP","EURBGN","EURCAD","EURCLP","EURCNY","EURCOP","EURCRC","EURHRK","EURCUP","EURCZK","EURDKK","EURVAE","EUREGP","EUREUR","EURFJD","EURGTQ","EURHKD","EURHUF","EURISK","EURINR","EURIDR","EURILS","EURJMD","EURJPY","EURJOD","EURKES","EURKWD","EURLAK","EURLVL","EURLTL","EURMOP","EURMYR","EURMUR","EURMXN","EURMNT","EURMMK","EURNAD","EURTWD","EURNZD","EURNOK","EURPKR","EURPAB","EURPGK","EURPYG","EURPEN","EURPHP","EURPLN","EURQAR","EURRON","EURRUB","EURZAR","EURSAR","EURSCR","EURSGD","EURKRW")

and the full response by Yahoo, including diagnostics output: http://pastebin.com/aYbptUte

by
4 Replies
  • I have the same memcache error when running YQL searches as well with that same IP address as the failing node as yours. My queries also work as you mentioned in the console. I've been using YQL for a while now and haven't had the problem until December.

    1
  • Tony, thanks. Please consider to report this as a bug via the bug reporting form in the YQL console! I already did so but if more people report it it might get a higher priority.

    Here is the bug submission form: http://screencast.com/t/8UDhZCseVsf

    1
  • Yea, I put in a bug report on December 4th. Hopefully this gets resolved quickly.

    0
  • I am getting this error frequently again. Same memcache server IP.

    1

Recent Posts

in YQL