0

Error Retrieving Data from External Service

Whenever I run the following YQL in the console, I see a diagnostic message saying "Error Retrieving Data from External Service":

select * from microformats where url = 'http://zarah5v2.livejournal.com/15514.html'

I've tried a variety of URLs and most give the error, but does it mean that there are no microformats on the page or that the page could not be read (or something else entirely)?

Congratulations on the launch of YQL, it's shaping up to be a very exciting service!

by
3 Replies
  • QUOTE (andymurd @ Jan 30 2009, 02:25 AM) <{POST_SNAPBACK}>
    Whenever I run the following YQL in the console, I see a diagnostic message saying "Error Retrieving Data from External Service":

    select * from microformats where url = 'http://zarah5v2.livejournal.com/15514.html'

    I've tried a variety of URLs and most give the error, but does it mean that there are no microformats on the page or that the page could not be read (or something else entirely)?

    Congratulations on the launch of YQL, it's shaping up to be a very exciting service!


    The microformats are processed and stored in Yahoos search index, which is where YQL gets the information from. So its possible that some of the pages you're looking at aren't in the index itself, and (as you thought) some may not have microformats in. In both of those situations the error message isnt really helpful - and we'll look at getting something better reported.

    Thanks
    Jonathan
    0
  • QUOTE (Jonathan @ Jan 30 2009, 01:30 PM) <{POST_SNAPBACK}>
    The microformats are processed and stored in Yahoos search index, which is where YQL gets the information from. So its possible that some of the pages you're looking at aren't in the index itself, and (as you thought) some may not have microformats in. In both of those situations the error message isnt really helpful - and we'll look at getting something better reported.

    Thanks
    Jonathan


    Hi Jonathan,

    I'm trying to run a YQL on a website as well (www.quiminet.com/quiminews), but I think the page that is indexed in Yahoo does a redirect and I'm getting the same error as the OP. Could this be the cause? Or is there something I'm missing?
    0
  • Can you describe what's not working for you?

    There don't appear to be any microformats for that page but the query:

    select * from microformats where url='http://www.quiminet.com/quiminews'

    Does return some information.

    Jonathan
    0

Recent Posts

in YQL