Cannot connect from one server, can from others. Blocked IP?

I wonder if anyone can tell me whether my production server's IP address has been blocked from accessing the YQL service - public or authenticated? I run two servers from the British Museum that use YQL to power retrieval of information from geoplanet, flickr and various YQL tables I contributed to datatables. I can connect fine from my backup server via curl ( - beta.finds.org.uk), but I get timed out and then get curl: (7) couldn't connect to host - which is - for my production server ( - finds.org.uk). I've tried wget and file_get_contents and both of those also return timeouts.
Everything was working fine until Sunday afternoon (has been for around 6 months), but now I can't get any data back, which is hamstringing my app rather badly. I don't think I've broken the ToS and I'm using Oauth to sign all my requests for data to leverage the higher rate limit.
I have no rules in my iptables configuration, flushed dnscache and restarted services to see if this clears the issue.

My traceroute for the production box:
traceroute to (, 30 hops max, 40 byte packets
1 ( 0.433 ms 0.485 ms 0.569 ms
2 ge-0-1.cad1.cad.dedipower.net ( 0.376 ms 0.391 ms 0.433 ms
3 ge-0-1-0.asr.thn.dedipower.net ( 1.852 ms 1.858 ms 1.853 ms
4 ge-1-1-0.pat1.the.yahoo.com ( 2.357 ms 2.251 ms 2.271 ms
5 so-0-0-0.pat2.ams.yahoo.com ( 7.766 ms 7.772 ms 8.006 ms
6 xe-0-1-0.msr1.ch1.yahoo.com ( 37.002 ms 37.228 ms 37.280 ms
7 gi-1-4.bas-a2.ch1.yahoo.com ( 36.970 ms gi-1-1.bas-a2.ch1.yahoo.com ( 38.085 ms gi-1-4.bas-a2.ch1.yahoo.com ( 37.049 ms

Traceroute for backup box:
traceroute to (, 30 hops max, 40 byte packets
1 ( 0.392 ms 0.467 ms 0.529 ms
2 ge-0-1.cad1.cad.dedipower.net ( 212.593 ms 212.652 ms 212.706 ms
3 ge-0-1-0.asr.thn.dedipower.net ( 1.831 ms 1.834 ms 1.829 ms
4 ge-1-1-0.pat1.the.yahoo.com ( 2.143 ms 2.101 ms 2.048 ms
5 so-0-0-0.pat2.ams.yahoo.com ( 8.049 ms 7.882 ms 7.897 ms
6 xe-0-1-0.msr1.ch1.yahoo.com ( 37.527 ms 37.223 ms 37.472 ms
7 gi-1-4.bas-a1.ch1.yahoo.com ( 32.222 ms gi-1-1.bas-a1.ch1.yahoo.com ( 32.105 ms gi-1-4.bas-a1.ch1.yahoo.com ( 32.274 ms

If there's other information that can help, let me know (I'm an archaeologist really and I'm making up this development stuff as I go along!)
I know there's been issues with dataservers this week, but I can't see why I cannot connect. If I have been blocked, how can I get unblocked and stop it happening again? Would be great to get service access restored as YQL rocks and I've been pushing other museums to use it.

5 Replies
  • Hi Dan,

    Are you still not able to connect to YQL?

    What queries are you making and to which tables?

    Thanks -Paul
    YQL Team
  • Hi Paul,
    Thanks for responding. I am still unable to connect, exactly the same problems. I can't even get the 404 page up for http://query.yahooapis.com via that box, but can from others. I'm using the following tables in my app with caching:
    britishmuseum, blackcountryhistory,brooklyn,victoriaandalbert,digitalnz,twfy, museumoflondon, opencontext - all methods in each of these sets
    Flickr, geo - most methods in each of these and data
    So for example I can't get thsi query from a json feed from my site to come up via curl: http://query.yahooapis.com/v1/public/yql?q...ltableswithkeys to come up on the, but I can on
    So I'm still thinking I've been blocked. I have a flickr module that retrieves photos by tags and google heavily indexed it at the weekend, this might have hit your server rather alot so could be the root cause.
  • Hi Dan,

    We are experiencing some transient issues... We should have a resolution soon.

    Thanks -Paul
  • I am having the same issue and it looks like it's general, not only related to my tables. I did the next test.


    This is from http://derekville.net/2010/how-to-secure-o...-in-javascript/

    And when trying to access the link from any computer in Romania and tried from an German IP too I get the "The current table 'twitter.status.timeline.friends' has been blocked. It exceeded the allotted quotas of either time or instructions" message.

    If I do this from an US ip address it works.

    What is happening? My website is in the same situation ( www.carteapenet.ro). It does not work from Romania or Germany, but it works from State.

    Thank you,

    QUOTE (Paul Donnelly @ Nov 12 2010, 01:59 PM) <{POST_SNAPBACK}>
    Hi Dan,

    We are experiencing some transient issues... We should have a resolution soon.

    Thanks -Paul
  • Hi Paul,
    Thanks for the update, you're probably aware that I can't connect still. I can via a proxy. It would be brilliant to get this resolved.

    Valentin, I think we have different problems, but I have seen the blocked table issue - usually when I've been using the multiquery community table.


Recent Posts

in YQL