0

Inconsistent responses from YQL console for firehose query

HI - I'm exploring the Yahoo Firehose YQL query via the YQL console and I'm getting inconsistent behavior. Most times the query returns zero responses and occasionally I get a resultset. I've attached 2 screenshots from sequential queries.

Anyone else seeing this behavior? Is this a known issue?

Cool data here, but I'm not feeling very confident that it's reliable.

Screenshot of query with no results (note the count=0 and results=null)


Screenshot of very next query with 10 results


Rob Johnson
Gnip

by
1 Reply
  • After further exploration, this seems to be related (as a theory) to "execution time". Empirically, any queries that take over 1000 (don't know the units here) tend to return zero results, those that take less than that succeed.

    In my usage, the firehose query "Select * from social.updates.search;" in the YQL console often takes over 1000 (units?) to complete.


    QUOTE (Rob Johnson @ Jul 9 2010, 08:34 AM) <{POST_SNAPBACK}>
    HI - I'm exploring the Yahoo Firehose YQL query via the YQL console and I'm getting inconsistent behavior. Most times the query returns zero responses and occasionally I get a resultset. I've attached 2 screenshots from sequential queries.

    Anyone else seeing this behavior? Is this a known issue?

    Cool data here, but I'm not feeling very confident that it's reliable.

    Screenshot of query with no results (note the count=0 and results=null)


    Screenshot of very next query with 10 results


    Rob Johnson
    Gnip
    0
This forum is locked.

Recent Posts

in Updates Firehose