Fetch data for Mailchimp RSS

Hi there, I am so newbie here.

I just need to solve this issue, I did my first pipe to create a RSS for promotions and upcoming events for one of my customers: http://pipes.yahoo.com/pipes/pipe.edit?_id=ec79e9f98bfd965464cf31be4c2d6308

This is meant te be in a mailchimp campaign, so I have been told to add a fetch data label in the very top of the pipe, However I donĀ“t know how to do it.

Anybody knows?

Thanks in advance

4 Replies
  • Ivan, I ran your Pipe as is but it returned no output in the Debugger section at the bottom of the Pipes screen (http://pipes.yahoo.com/pipes/pipe.edit?_id=ec79e9f98bfd965464cf31be4c2d6308). You do this by clicking on the title bar of the "Pipe Output" box.

    I then checked the output for the Fetch Feed boxes by clicking on the title bar of the Fetch feed box I want to check and looking at the output in the debugger.

    The first time I ran this I got the following results:

    For your first feed I got the following response in the debugger: "Error fetching http://open.dapper.net/transform.php?dappName=Promociones&transformer=RSS&extraArg_title=Titulo&extraArg_description[]=Titulo&extraArg_description[]=Descripcion&applyToUrl=http%3A%2F%2Fhttp://www.farmaciaolimpiadas.com%2Fpromociones-actuales%2F. Response: OK (200). Error: Read timed out."

    For your second feed I got the following response: "Error fetching http://open.dapper.net/transform.php?dappName=Eventosproximos&transformer=RSS&extraArg_title=titulo&extraArg_description[]=descrpcion&applyToUrl=http%3A%2F%2Fhttp://www.farmaciaolimpiadas.com%2Feventos-proximos%2F. Response: OK (200). Error: Read timed out."

    After waiting several minutes I clicked on the first Fetch Feed box title bar again and results were returned. I then clicked on the pipe Output box title bar and results were returned again. The last sentence in the above quoted responses indicate a Server issue in returning the results and this is supported by the results I eventually did get, in that if no results are returned from an inquiry with a "time out" message and then results are returned from a subsequent query to the server a short time later, this this will usually indicate such.

    However, when I actually ran the Pipe itself rather than just checking the Debugger output I got a list of results but any that had an image also showed a "null" result with no text results displayed. Results that had no image did show text. However, in both cases the link in the results does not link to the original source and will only open another Pipes screen with the same results. The links shown here should open the original source. Is this consistent with what you were getting?

    I also took the URL component displayed in the above quoted responses and ran these from my browser to see if they were valid links. They were and took me to my browser's RSS setup screen where I could add them to my Feed Reader which I did successfully.

    I also noticed that your pipe queries are to the open.dapper.net service. I had tried using this service a month or so ago and kept getting errors and/or it would simply hang while attempting to retrieve data.

    After some preliminary checking on the net at that time I found that issues with the Dapper service were quite common and some information I found even indicated that it was either no longer running or was not being supported by Yahoo. It might be time for me to look at that again.

    In reference to the Fetch Data question, this module is only used to extract data from any XML, JSON, iCal or KML sources and not from RSS Feeds. If all you are doing is pulling data from RSS feeds the Fetch Data module is of no use to you. If, however, you want to pull data from web pages that do not provide an RSS feed or to access public data from a website that is not specifically included in any RSS feeds for that site then you do need to be using the Fetch Data module.

    Also, can you elaborate on how you are trying to use the Pipe in conjunction with the MailChimp service. I

  • In conclusion, I just tried running the URL section of the above quoted response messages again and it will not connect to Dapper at all now. The browser tab just displays "connecting" with a revolving circle icon. Hang on, now it has completed but did not return any results as it could not retrieve any. See screen shot here. https://www.diigo.com/item/image/12zvv/ade0.

    This supports my previous experience with Dapper and this last test I did was simply taking your Dapper Feed URL and plugging it into my browser to add it to my Feed Reader. So this was entirely outside of Yahoo Pipes. So at least it seems that most or possibly even all of the issues are with Dapper and not Yahoo at this point. Having said that though, both Dapper and Pipes are Yahoo services.

    Also, in reference to being able to successfully add an RSS feed to my Reader for your Dapper URL links, I did not actually click on the links in my Reader to see what they opened. I was just checking to make sure my Reader regarded them as a valid RSS link, which it did. The issue as to what content is displayed is another one altogether.

    Hope that may help in some small way.

  • Peter Willis, this is so much help I could have imagined!

    Thanks so much for this awesome information.

    What I understand is I should start fresh from the begining whithour using dapper, right?

    I am still trying to digest all the valuable info.

    Thanks again, I will keep you informed.

  • You're welcome Ivan. I am still a relative newcomer to Yahoo Pipes myself and in my searching and information seeking if I come across a post I think I can assist with I am only too happy to do so.

    And no, I would not be relying on Dapper, but I have not completely written it off either as there are indications it is still active. Maybe the Yahoo Servers running Dapper are not capable of handling high demands or are also being deployed to provide other Yahoo services as well and this is impacting on the Dapper load.

    That is only speculation on my part and it does seem surprising that a company the size of Yahoo would not devote sufficient resources to its online services, but having said that, the Dapper service may not be a priority as it was bought by Yahoo in 2010 for its ad based services but from what I can glean online that seems to have been a commercial decision to eliminate competition for ad services so Yahoo can expand their services in this area.

    Recent news headlines indicate that this is the case as Yahoo wants to expand its market for ad services currently dominated by Facebook and Google.

    Let us know how you go.


Recent Posts

in Pipes