0

Fetch CSV other objects cannot pick-up attributes need help desperately

Hi,

http://pipes.yahoo.com/pipes/pipe.edit?_id=2bf6722485af21d10aeca77fbe958449

Nomatter how hard I try, I cannot seem to create a fetch CSV pipe. It always results in nulls. I think this is caused by something that is wrong behond my reach and not because I'm doing something wrong.

One of the indications is that the rename object is not picking up the atributes of the fetch csv object, despite them showing in the debugger.

I've tried the folliowing things:

1) Create a YQL CSV query and attach the rename function. The rename function comes back with the default attributes, not those in the YQL query. 2) Altered the CSV link in an fetch CSV example. For some reason, those pipes keep getting the old CSV fetch and the rename function does not show the new attributes. 3) Rebuild exactly the same example from scratch, using the datasource (csv) from the example. IS NOT POSSIBLE. 4) Created a new Yahoo profile. Is not working. 5) Deleted the rename object from the example, and put it in again. Rename is no longer showing the right attributes despite it reporting "updating".

May be I don't understand the principles of pipes, but I desparately need help with this…

Please help me,

Roland Zoet

by
6 Replies
  • Your problem is with those columns where the heading contains a dot. If you cannot change the column headings in the source then set the CSV to skip the first row and then select "Use the following column names:". You can then leave the column names blank to get the default Pipes column names or create your own.

    0
  • Thanks for your suggestion. Its not working, I suspect there is something wrong with my account.

    1) Created a new CSV and a new pipe, replaced the dots with underscores. This can be seen here:

    http://pipes.yahoo.com/pipes/pipe.info?_id=0a096531ed67d2d1563a891e72876e4f

    2) Created a new pipe and did what you suggested: skipped one row and made my own columns. NOT picked up in rename function.

    http://pipes.yahoo.com/pipes/pipe.info?_id=7557ae77b66e9a307fddc4bf58142b91

    Could jou do me a favour:

    Create the same very simple query under 1 and see if it works with you? If this is the case then there is something wrong with my account.

    Thanks a lot in advance.

    0
  • Thats true, but this is because the left hand side of the rename object doesn't contain the attributes of the csv, so there's no point. However yours doesn't also (1) thus I tried recreating yours under 1

    http://pipes.yahoo.com/pipes/pipe.info?_id=19e3d9c94d337e19b0c3fa17853d90c4

    Still gives Nulls. I tried this a couple of times and sometimes it give nulls and sometimes it works Also when I change something, it doesn't follow my orders, but stil runs the old pipe.

    http://pipes.yahoo.com/pipes/pipe.info?_id=6d8b19fb0e8fa6d82b11731237930947

    First I removed the rename, when that didnt give any effect, I even removed the fetch CSV, IT STILL worked for a while and then somehow it started reporting the correct way.

    So far my conclusions are:

    1) At random, it either works or it doesn't. Mostly it doesn't. I don't know how to reproduce that. I tried saving the pipe and going back to my pipes instead of directly running it, but it doesn't make any difference. 2) When you alter the pipe, it doesnt pick up those alterations in the actual query 3) It keeps runing the original query, even if I destroy the query internally. 4) I doesn't pickup the attributes from the CSV in for instance rename, although this is obviously the intention (because its updatingvalues after connection of fetch_csv and rename). 5) Because I at forehand don't know if the query will work and most of the times it doesn't I cannot use it, because I can't be trying forever. Moreover complex queries are impossible this way. What kind of buggy BS product is this? 6) I switched from safari to firefox and it seems to work better. I will work with firefox for a while tot see if this gives reliable results

    0
  • You can type in attributes into the Rename module.

    In example 1 the filed name I use in the Rename is

    item.GC_RANK_target-geo-id

    You have not copied that correctly.

    Pipes caches results for 15 minutes. This means that you may have to wait for 15 minutes before any changes you make in your pipe are reflected on the run page or in the RSS output.

    0
  • Aha, sorry about that. However the fact that rename (and other objects) do not pickup the attributes of the fetch object and the delay of 15 minutes makes it quite difficult to test a complicated query. I guess the best thing to do is to break it into little peaces first. If you make a mistake (like I did twice) it could be a while before you can actually discover it. Thanks for your help! I may ask your help with the real queries I want to make. This is a painstakingly tedious learning curve.

    Thanks again

    0

Recent Posts

in Pipes