Extracting a url from discription and creating link

I am currently working on a project that now seems to be well beyond my skill set. Its a simple project: I need to gather news about a specific subject from various websites using Dapper, then filter and output as RSS feeds using Pipes.

I've played a bit with Dapper and Pipes and almost achieved everything I needed but ran into some problems. I succesfully created a RSS feed from one of my primary sourse website using Dapper. (This site has a news page which only displays titles, pictures, dates and Discription but not the full article. The url for the full aricle is at the bottom of the the discription as "click here to read more") I was able to copy the url in the body of the RSS feed created by Dapper, however onece I get the Pipes to filter and sort, my nightmare began, I would like to list the source url as the item.link but I do not know how to extract the article source url.(The article source url is in item.discription and is in HTML) Here is my pipe, please take a look: http://pipes.yahoo.com/pipes/pipe.edit?_id=10da909bbe0cc3767348bb93f069c7d3 Can someone walk me through this process, I am a novice so step by step please. Thanks in advance.

3 Replies
  • I'm in the same trouble.

  • Hello,

    I would advise you to use the XPath Fetch Page module or the deprecated Fetch Page module instead of Dapper that I didn't know, you'll get more content. (something like that: http://pipes.yahoo.com/luneart/b93745a2a55735cd221120fd3b0c6587 )

    However, using Dapper, what you need to do is the extract the URL from description and put it in item.link, and extract the URL picture and put it item.<media:thumbnail.url> or item.<media:content.url> (or both). Those are standardized RSS fields that any RSS reader will understand. To do so, first create those fields by copying the description field, then use regexs to extract relevant data. Something like that: http://pipes.yahoo.com/luneart/42a963be981e096f3ba140c243b41f0b

    enjoy :)

  • Thank you Lolo, I really really appreciate the help. However, It looks fine in the debugger but once I post it to my site the source url is there but not the picture. I tried adding <media:thumbnail.url> also but still no dice. Let me know if you are interested in taking on a new project.


Recent Posts

in Pipes