Using "yahoo.com" as provider URL fails, "me.yahoo.com" works


I noticed a strange behavior lately when people tried to login on my website using OpenID and Yahoo. When we went online a couple of months ago, everything worked as expected using "http://yahoo.com" as the provider URL for Yahoo. But since a couple of weeks, login/registration stopped working. The error occurres in python-openid, in this code block:

    result = DiscoveryResult(uri)
resp = fetchers.fetch(uri, headers={'Accept': YADIS_ACCEPT_HEADER})
if resp.status not in (200, 206):
raise DiscoveryFailure(
'HTTP Response status from identity URL host is not 200. '
'Got status %r' % (resp.status,), resp)

The value of uri is "http://yahoo.com", the value of YADIS_ACCEPT_HEADER is 'text/html; q=0.3, application/xhtml+xml; q=0.5, application/xrds+xml'. If I use "http://me.yahoo.com", everything works as expected. But on sites like Stackoverflow, "http://yahoo.com" works, too.

Is this a problem with python-openid or did Yahoo change something in their OpenID configuration? As I said, "http://yahoo.com" used to work just fine until a couple of weeks ago.

Thanks for your help!


1 Reply

Recent Posts

in OpenID General Discussion