Could somebody please help me.

For the first time, I'm trying to use oauth to sign a simple Yahoo! web query via a GET method.

I'm getting the following error page:

"Please provide valid credentials. OAuth oauth_problem="unable_to_determine_oauth_type", realm="yahooapis.com""

I'm confident that my HMAC-SHA1 code is working a treat, the problem seems to be the construction of the Base String and exactly which bits of it need URL escaping.

My base string is (line breaks only for readability) :

&oauth_consumer_key=xyz...hidden for security reasons...abc--

Notice how '&' is used twice before escaping comes into effect - just like Yahoo! shows on their page http://developer.yahoo.com/oauth/guide/oauth-signing.html

3 Replies
  • I've read http://tools.ietf.org/html/rfc5849#section-3.4.1 and http://tools.ietf.org/html/rfc5849#section- - so now my parameters are in alphabetic order, removed the parameters format, style and abstract just to keep things simple. Still no joy.

    It's like threading a needle in a blacked-out room whilst wearing boxing gloves tied behind your back!

  • same here

  • I am getting the same error too for no different reason. Because my other website works.


Recent Posts

in OAuth General Discussion YDN SDKs