12

signature_invalid when making calls to the Profiles API

Hello,

I have suddenly started experiencing problems with invalid OAuth signatures when making authenticated calls to the profiles API:

{"error":{"lang":"en-US","description":"Please provide valid credentials. OAuth oauth_problem=\"signature_invalid\", realm=\"yahooapis.com\""}}

My code has worked without any problems for long time.

Here are some facts:

  • My code hasn't changed
  • My code works if I run it from a server hosted in Europe
  • My code fails if I run it from a server hosted in the USA

In order to narrow down the problem I have followed the example suggested in this article and wrote the following sample console application: http://snipt.org/Brz6

The result is still the same:

  • This application works if I run it from USA
  • It fails if I run it from Europe.

Do you have any idea what could be the possible reason for that?

by
  • FN
  • Nov 29, 2013
21 Replies
  • Same problem here, our code did not change.

    2
  • Same here

    2
  • Same problem, my server is in Europe ... the code no change...

    2
  • Same problem, my server is in Europe ... the code no change...

    2
  • NB : same problem to retreive contacts and profile, from US and Europe

    2
  • same here

    2
  • I'm seeing the same problem here. My application was initially throwing intermittent 500 errors but a retry usually got around that, however, since at least November 27th has been throwing consistent 401 Invalid Signature. The code hasn't changed and after an extensive debugging trawl, the code is fine - the function generating the OAuth Signature is working fine when getting the Access Token, so it shouldn't be an invalid signature when making the request against the Social API endpoint.

    It would be nice if this could be resolved quickly. It's at least a week since the 401s became constant.

    1
  • Same problem here, our code did not change.

    1
  • Same problem here, help....

    0
  • Same problem in China.

    0
  • same issue from today onwards..

    0
  • Now its working , I think Yahoo Developers fixed their Oauth Issue

    -1
  • Authentification seems fixed but retrieve profile and contacts informations doesn't work.

    -1
  • Authentification seems fixed but retrieve profile and contacts informations doesn't work.

    -1
  • Current error message : {"error":{"uri":"http://www.yahooapis.com/v1/errors/500","lang":"en-US","description":"Internal server error","detail":"ContactAPIAddressBookClientException viewer: MCWFXINZLYLEXYHNUH3O6V7JPQ ab_client errorcode: -17011 errormsg: client connection error"}}

    -1
  • Hi,

    Same problem on our side but at the moment we experienced only on EU cluster. For US cluster (Mexic, US, Canada) still can use the Oauth implemented.

    Can anyone tell me if there were an official information related to this topic and maybe an ETA ?

    -1
  • Today did not receive error 500, hope tomorrow too will be the same

    -1
  • We're still seeing ContactAPIAddressBookClientException errors, how do we fix this?

    -1
  • i still getting the same error, {"error":{"lang":"en-US","description":"Please provide valid credentials. OAuth oauth_problem=\"signature_invalid\", realm=\"yahooapis.com\""}}

    Can any one confirm where is problem actually. Here is my code and question http://stackoverflow.com/questions/20948988/yahoo-api-call-signature-invalid

    0
  • still same problem but i have one question which oauth_signature used when call profile Api. beacuse when i call get_request_token api so pass oauth_signature=YAHOO_CONSUMER_SERECT_KEY,but when i call get_token api so pass oauth_signature=YAHOO_CONSUMER_SERECT_KEY+oauth_token_secret(which one we get thru get_request_token api).after i get GUID but now when i call profile api so i get same error {"error":{"lang":"en-US","description":"Please provide valid credentials. OAuth oauth_problem=\"signature_invalid\", realm=\"yahooapis.com\""}}

    please help me ..thanks

    0
  • it's amazing to see that every single person is telling the same thing: "it doesn't work" and "ouin, ouin". It's not what one expects from a forum dealing with professionnal issues, can't see anything helping. When I read comments, it seems to me that deaf, dumb and blind people are trying to communicate together, which usefull for nobody, and useless for all.

    0

Recent Posts

in OAuth General Discussion YDN SDKs