Signature_invalid (Desktop Application)

Dear all

I make a request to get request token with HMAC-SHA1. But always get the response with signature_invalid. Do I miss something?

consumer key: dj0yJmk9aTBub2pMeU1tVUtUJmQ9WVdrOVZIVmtTWEJoTXpZbWNHbzlOemcxTlRJek1EWXkmcz1jb25zdW1lcnNlY3JldCZ4PWQ1 consumer secret: dbb4b888ab0ec96f7faf3a210bd7404943003893

Base <string:GET&https%3A%2F%2Fapi.login.yahoo.com%2Foauth%2Fv2%2Fget_request_token&oauth_callback%3Doob%26oauth_consumer_key%3Ddj0yJmk9aTBub2pMeU1tVUtUJmQ9WVdrOVZIVmtTWEJoTXpZbWNHbzlOemcxTlRJek1EWXkmcz1jb25zdW1lcnNlY3JldCZ4PWQ1%26oauth_nonce%3D51896%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1372748684%26oauth_version%3D1.0%26xoauth_lang_pref%3Den-us>

my http request format: Method : GET host: api.login.yahoo.com url: /oauth/v2/get_request_token/?oauth_callback=oob &oauth_co nsumer_key=dj0yJmk9aTBub2pMeU1tVUtUJmQ9WVdrOVZIVmtTWEJoTXpZbWNHbzlOemcxTlRJek1EWXkmcz1jb25zdW1lcnNlY3JldCZ4PWQ1 &oauth_nonce=51896 &oauth_signature_method=HMAC-SHA1 &oauth_timestamp=1372748684 &oauth_version=1.0 &xoauth_lang_pref=en-us &oauth_signature=T61dFUl18qZFagGrhdP8MzrHX2s%3D

But, I can successly get the token with PLAINTEXT. I have no idea about this part.


3 Replies
  • no body can help me to resolve this problem? I test the HMA-SHA1 result with the result of HMA-SHA1 online app. I got the same result . But , the signature still not be accepted by Yahoo. Do I have anyting wrong or missing? please help me to resolve the problem.

    thanks .


  • Same problem here, fails with HMA-SHA1 but works for plaintext.

    Can yahoo developers suggest what the hell is going on?

    I verified signature with request base string and It was right but signature is always returned as signature_invalid.

  • Did you check if your normalized your parameters match what Yahoo is expecting prior to sending creating the HMA-SHA1 signature?

    As per, http://developer.yahoo.com/oauth/guide/oauth-signing.html

    try printing the output prior to the signing and see if theres a mismatch.


Recent Posts

in OAuth General Discussion YDN SDKs