1

Cannot connect to notification server

I made a simple test app a couple of days ago, using long polling to get notifications. Everything was working fine, receiving notifications as expected. Today I got back to it and now I can no longer receive any notifications. The server I'm using (from the previous session api call response) is "rproxy1.messenger.yahooapis.com". There is no HTTP error response returned, its simply a connection error - looks like the server is refusing the connection at the TCP level when I run Wireshark on the network traffic. Any idea whats going on here? Are Yahoo's servers just that flaky, or is my IP being blacklisted or something (although I've tried it from to different IP addresses)? Very frustrating not having way to troubleshoot this.

by
3 Replies
  • You're not alone. The problem seemed to start last night at 10:45 PM PST.

    I managed to switch my app to using the /v1/notifications URL but I can only poll for messages once every minute otherwise Yahoo kicks me out with the dreaded 999 error (too many requests).

    $ telnet rproxy1.messenger.yahooapis.com 80
    Trying 216.155.195.253...
    telnet: connect to address 216.155.195.253: Connection refused
    telnet: Unable to connect to remote host
    
    $ telnet rcore1.messenger.yahooapis.com 80
    Trying 216.155.194.68...
    Connected to ydnrws1.msg.vip.sp2.yahoo.com.
    

    Weird thing is there is a server called rproxy2 which connects, but it rejects my imtoken when I try to connect. Any way we can get access to this server?

    0
  • Looks like the session call is now coming back with 'rproxy2.messenger.yahooapis.com" and it does seem to be working now with this one. Hope the 24 hour down time is an exception rather than the norm!

    0
  • Maybe I spoke too soon. Now its intermittent with rproxy2 - sometimes coming back with a 403, sometimes succeeds, sometimes back to connection refused. Oh well ...

    0

Recent Posts

in Messenger IM SDK