0

could not upload widget: error parsing widget.xml from widget file

When I try to upload the widget, it always show me the error , e.g “ could not upload widget: error parsing widget.xml from widget file
So what are the precautions to take for uploading the widget? I think the error generates because of wrong name assign to directory.
My xml file data is as below.


<metadata>
<name>DreamTV</name>
<version>2.0.0</version>
<identifier>com.dreamtv.widgets.tv.video</identifier>
<author name="DreamTV Test" organization="DreamTV System Inc." href="http://www.dreamtvs.com" />
<copyright>2010</copyright>
<description>DreamTV Media player widget</description>
<platform minVersion="5.0" />
<security>
<filesystem>full</filesystem>
<command>true</command>
<http>all</http>
<debug>on</debug>
</security>
<image usage="1920x1080.logo" src="Images/1920x1080/logo.png"/>
<image usage="960x540.logo" src="Images/960x540/logo.png"/>
</metadata>

And directory name is com.dreamtv.widgets.tv.video.widget
After zipping the file should I have to change .zip to .widget? so my directory will be com.dreamtv.widgets.tv.video.widget.widget . is it o.k. that 2 times widget extensions I am using.
Please help me . where I am wrong.
Thanks in advance.

by
4 Replies
  • QUOTE (DEEPKUMAR @ Nov 19 2010, 10:45 AM) <{POST_SNAPBACK}>
    When I try to upload the widget, it always show me the error , e.g %u201C could not upload widget: error parsing widget.xml from widget file%u201D
    So what are the precautions to take for uploading the widget? I think the error generates because of wrong name assign to directory.
    My xml file data is as below.


    <metadata>
    <name>DreamTV</name>
    <version>2.0.0</version>
    <identifier>com.dreamtv.widgets.tv.video</identifier>
    <author name="DreamTV Test" organization="DreamTV System Inc." href="http://www.dreamtvs.com" />
    <copyright>2010</copyright>
    <description>DreamTV Media player widget</description>
    <platform minVersion="5.0" />
    <security>
    <filesystem>full</filesystem>
    <command>true</command>
    <http>all</http>
    <debug>on</debug>
    </security>
    <image usage="1920x1080.logo" src="Images/1920x1080/logo.png"/>
    <image usage="960x540.logo" src="Images/960x540/logo.png"/>
    </metadata>

    And directory name is com.dreamtv.widgets.tv.video.widget
    After zipping the file should I have to change .zip to .widget? so my directory will be com.dreamtv.widgets.tv.video.widget.widget . is it o.k. that 2 times widget extensions I am using.
    Please help me . where I am wrong.
    Thanks in advance.

    I was not able to reproduce this particular error message. The xml is well-formed, even though you're not including a declaration. And in answer to your question, the widget should be zipped with only 1 .widget extension (however uploading with 2 .widget extensions doesn't harm anything).

    If you'd like, you can send me your zipped widget at tvwidgets [at] yahoo-inc [dot] com. Send it to my attention, and I'll try to upload it.

    On a side note, please don't post the same question in multiple forums. For those of us that subscribe to them, it doubles the amount of mail I get. Not fun ;)- Ben
    0
  • QUOTE (Benjamin Toll @ Nov 19 2010, 12:19 PM) <{POST_SNAPBACK}>
    I was not able to reproduce this particular error message. The xml is well-formed, even though you're not including a declaration. And in answer to your question, the widget should be zipped with only 1 .widget extension (however uploading with 2 .widget extensions doesn't harm anything).

    If you'd like, you can send me your zipped widget at tvwidgets [at] yahoo-inc [dot] com. Send it to my attention, and I'll try to upload it.

    On a side note, please don't post the same question in multiple forums. For those of us that subscribe to them, it doubles the amount of mail I get. Not fun ;)Again thanks.
    0
  • QUOTE (DEEPKUMAR @ Nov 19 2010, 02:01 PM) <{POST_SNAPBACK}>
    Thanks for replay Ben,
    And next time I will add forum only one time. I will keep in mind.

    Thanks for interest but actually I solved the error and now I successfully upload the widget.
    Actually I made mistake to define the xml file. Some tags were missing after correcting them I was able to upload it. I was confused at that time because I was afraid , may be there will some rule that I forget in naming conversion or I fill wrong data at uploading time.
    But now it is o.k. I am going to teat with TV.

    Again thanks.

    That's odd, I had copied your xml verbatim and was able to successfully upload it to the gallery. Anyway, I'm glad you sorted it out.

    - Ben
    0
  • well, how did you sort it out

    0

Recent Posts

in Getting Started / Beginners - Yahoo! TV Widgets