0

Unable to view uploaded widget on Simulator

Hi,

I have uploaded my widget "com.est.widgets.tv.helloworld-1.0.0.widget" using the widget upload tool (http://gallery.tv.widgets.yahoo.com/publisher/) as mentioned in YWE_Developer_Guide.pdf (pg 85, 86). After filling all the details (see below), I got a confirmation, wigdet uploaded successfully. Also, I can see my uploaded widget in "My Widgets" on the upload site. But, even after 2 hours or so, I am not able to view my uploaded widget in my simulator. I had added the developer codes for 3 simulators (all 540) - Latest 540 - 44T8, LG - MUBY, Samsung 1.2 - VAMN. I have not done reset on the simulator to maitain the developer codes and also enabled the developer mode ON on each. I have followed naming convention also and also my identifier is also correct "com.est.widgets.tv.helloworld" in widget.xml.

What could be the problem? Has anybody faced similar issue? Please guide me in this.
I have restarted the simulators many times but no avail.

Thanking you.

Regards,
Azhar

My platform details -
1. Ubuntu Linux 8.04 running in Vmware on Win Vista.
2. Yahoo WDK - ywe-wdk-0.9.7.6-i386

My widget upload details -
Widget ID: com.est.widgets.tv.helloworld
Widget Version: 1.0.0
Author Name: Azhar Bashir Khan
Author Company: Endeavour
Author Email: azharbk2009@yahoo.com
Gallery Widget Name: EST ABK Hello
Gallery Publisher Name: ABK
Gallery Widget Description: ABK EST Hello World widget development
Developer Codes: azharbk2009: MUBY,44T8,VAMN

by
6 Replies
  • Why are you trying to install something in the simulator which you uploaded via the gallery? The gallery uploading is only for testing / shipping on a device. For testing in the simulator, simply copy the widget into the /devwidgets folder.

    -Jeremy
    0
  • Hello Jeremy,

    Yes, I know that. But, I just wanted to go through the process of uploading and deployment via upload widget tool. We have got a TV now and are in process to deploy the test widget on TV. My concerns are -
    1. What should i put in the "Gallery Publisher Name:" field (I have just put my initials there)?
    2. How long after successful upload with proper developer code and tester, does the test widget come on actual TV? I mean what is the process, should I keep the TV ON after loggin in and switching the developer mode ON? how long? or restart the TV, etc.? Can you please provide insight into this.

    Thanking you. Appreciate you response.

    Regards
    Azhar

    QUOTE (Jeremy Johnstone @ Jan 27 2010, 05:20 PM) <{POST_SNAPBACK}>
    Why are you trying to install something in the simulator which you uploaded via the gallery? The gallery uploading is only for testing / shipping on a device. For testing in the simulator, simply copy the widget into the /devwidgets folder.

    -Jeremy
    0
  • Hello Azhar,

    This process is detailed in the documentation. After uploading to the gallery, you must follow the below steps:
    1. Go into the widget gallery and make sure you are logged in using the same Yahoo ID and the same dev code you registered on the website are shown.
    2. Go back to the main menu of the widget gallery and then select the "Categories" button at the bottom
    3. Switch to page 2 (in most cases) of the categories list and then select the "Test Widgets" category
    4. Pick your widget (probably the only one shown) and then select to install it.
    0
  • QUOTE (Jeremy Johnstone @ Feb 2 2010, 03:52 AM) <{POST_SNAPBACK}>
    Hello Azhar,

    This process is detailed in the documentation. After uploading to the gallery, you must follow the below steps:
    1. Go into the widget gallery and make sure you are logged in using the same Yahoo ID and the same dev code you registered on the website are shown.
    2. Go back to the main menu of the widget gallery and then select the "Categories" button at the bottom
    3. Switch to page 2 (in most cases) of the categories list and then select the "Test Widgets" category
    4. Pick your widget (probably the only one shown) and then select to install it.


    Hello Jeremy,

    I've met with the same problem as did Azhar. And to make it worse I followed your procedures but saw no Test Widgets category in the main view. There are still only three categories as before (Spotlight, Latest, All Widgets), NO SECOND PAGE at all.

    Besides, I notice there is a button called "Show My Test Widgets" defaulted to 'OFF' at the bottom of Widget Gallery/Developer Settings view and by clicking on it a screen prompted on which I input my yahoo id and password. "Show My Test Widgets" then turned to 'ON'. This part is not mentioned in the document and what is it supposed to do?

    nrgbooster
    0
  • QUOTE (nrgbooster @ Mar 10 2010, 10:11 PM) <{POST_SNAPBACK}>
    Hello Jeremy,

    I've met with the same problem as did Azhar. And to make it worse I followed your procedures but saw no Test Widgets category in the main view. There are still only three categories as before (Spotlight, Latest, All Widgets), NO SECOND PAGE at all.

    Besides, I notice there is a button called "Show My Test Widgets" defaulted to 'OFF' at the bottom of Widget Gallery/Developer Settings view and by clicking on it a screen prompted on which I input my yahoo id and password. "Show My Test Widgets" then turned to 'ON'. This part is not mentioned in the document and what is it supposed to do?

    nrgbooster


    I am having the same issue with simulator when displaying deployed apps. Do I have to get a real TV to see the "Test Widgets" options?

    Thank you.

    Yuhan
    0
  • QUOTE (YuhanZ @ Mar 30 2011, 02:45 PM) <{POST_SNAPBACK}>
    I am having the same issue with simulator when displaying deployed apps. Do I have to get a real TV to see the "Test Widgets" options?

    Thank you.

    Yuhan

    Yes, the test widgets category that was referred to in this post is what you'd see after you log in with your Y! id on your tv. You won't see the same category in the simulator.
    0

Recent Posts

in Getting Started / Beginners - Yahoo! TV Widgets