0

About TV Widget simulator

Hi, Guys,
Today, I just first time install WDK into my Ubuntu8.10 system, but I can't start any production simulator. the terminal always shows
" ERROR! ERROR! ERROR!
We can not establish an http conection which is required to
update widgets. Please check your network and proxy settings
(Appliations/TV Widgets/Simulator Settings menu).
....
"
I follow the instruction to updated proxy setting, but it still have same error. then I read the YWE_Developer_Guide.pdf again, at Page73, it say that
the first time simulator is started it attempts the following HTTP request:
% wget -O /dev/null $KF_PROXY $testurl -o /tmp/wvget.log
Then, I check the /tmp/wget.log file, after I run simulator, it's have a newest wget.log file in /tmp folder, I check the data in the this file, it shows the internet connection is fine. no problem.
I don't know where is wrong.
Waiting someone give me a hand. Thanks.

by
9 Replies
  • QUOTE (Yong @ Jan 14 2010, 06:09 PM) <{POST_SNAPBACK}>
    Hi, Guys,
    Today, I just first time install WDK into my Ubuntu8.10 system, but I can't start any production simulator. the terminal always shows
    " ERROR! ERROR! ERROR!
    We can not establish an http conection which is required to
    update widgets. Please check your network and proxy settings
    (Appliations/TV Widgets/Simulator Settings menu).
    ....
    "
    I follow the instruction to updated proxy setting, but it still have same error. then I read the YWE_Developer_Guide.pdf again, at Page73, it say that
    the first time simulator is started it attempts the following HTTP request:
    % wget -O /dev/null $KF_PROXY $testurl -o /tmp/wvget.log
    Then, I check the /tmp/wget.log file, after I run simulator, it's have a newest wget.log file in /tmp folder, I check the data in the this file, it shows the internet connection is fine. no problem.
    I don't know where is wrong.
    Waiting someone give me a hand. Thanks.

    I ran into the same issue. I had to comment out the check in /usr/local/bin/Konfabulator. I am using the same proxy as the previous emulators, but it does not work. I am using ubuntu 9.0.4 and GNU Wget 1.11.4.
    0
  • I looked into this a bit. Here are a few problems I seem to see with the script.

    1. The grep statement around line 220 is incorrect. For a request through a proxy, the log contains the following (GNU Wget 1.11.4)

    Proxy request sent, awaiting response... 200 OK

    instead of what the grep statement is looking for

    grep -i "HTTP request sent" /tmp/wget.log |grep -i "200 OK"

    2. The wget command used does not appear correct. Searching in the man pages, it does not appear that wget allows you to list your proxy on the command line. Instead the proxy needs to be set in an http_proxy environment variable, or in the /etc/wgetrc file. The current command is

    CODE
    wget -O /dev/null $KF_PROXY $testurl -o /tmp/wget.log


    3. $KF_PROXY does not have any value when I echo in the script where it does the wget. It appears the read_conf function is not called until after we are at this point.

    I may be missing something, but these are what initially seemed incorrect to me.
    0
  • Hi, Steve,
    Thanks for your kindly help. With your hint, now I can run Yahoo TV simulator.
    0
  • QUOTE (Steve @ Jan 15 2010, 05:09 AM) <{POST_SNAPBACK}>
    I looked into this a bit. Here are a few problems I seem to see with the script.

    1. The grep statement around line 220 is incorrect. For a request through a proxy, the log contains the following (GNU Wget 1.11.4)

    Proxy request sent, awaiting response... 200 OK

    instead of what the grep statement is looking for

    grep -i "HTTP request sent" /tmp/wget.log |grep -i "200 OK"

    2. The wget command used does not appear correct. Searching in the man pages, it does not appear that wget allows you to list your proxy on the command line. Instead the proxy needs to be set in an http_proxy environment variable, or in the /etc/wgetrc file. The current command is

    CODE
    wget -O /dev/null $KF_PROXY $testurl -o /tmp/wget.log


    3. $KF_PROXY does not have any value when I echo in the script where it does the wget. It appears the read_conf function is not called until after we are at this point.

    I may be missing something, but these are what initially seemed incorrect to me.

    There is also a problem if you use a none english wget version, because in this case the output in /tmp/wget.log is different, eg in German "HTTP Anforderung gesendet"
    0
  • Thanks Steve for helping track this down. I've forwarded the details to our person in charge of WDK releases and we will do our best to address this officially soon.

    -Jeremy
    0
  • This works for me:

    ===========================================
    Menu applications -> Accesories -> Terminal

    (a blank terminal command screen opens)

    $sudo nano /usr/local/bin/Konfabulator

    (enter administrator password)

    (nano editor window opens)

    Go to line 220 and edit:

    before:
    ------
    if [ ! $? = 0 ]; then
    echo "\n\mERROR! ERROR! ERROR!\n\nWe can not establish an http ...
    update widgets. Please check yor network an proxy setting \n ...
    read -p " " network_detect;
    exit
    fi

    after:
    -----
    #if [ ! $? = 0 ]; then
    # echo "\n\mERROR! ERROR! ERROR!\n\nWe can not establish an http ...
    #update widgets. Please check yor network an proxy setting \n ...
    # read -p " " network_detect;
    # exit
    #fi

    press CTRL + 0 to save changes
    RETURN to confirm file name
    press CTRL + X to exit
    Type EXIT to close Terminal window
    ==============================================

    I use Ubuntu 8.04 virtualized over Windows XP with Microsoft Virtual PC.

    Raul (spain)
    --------
    0
  • QUOTE (Raul @ Jan 18 2010, 11:36 PM) <{POST_SNAPBACK}>
    This works for me:

    ===========================================
    Menu applications -> Accesories -> Terminal

    (a blank terminal command screen opens)

    $sudo nano /usr/local/bin/Konfabulator

    (enter administrator password)

    (nano editor window opens)

    Go to line 220 and edit:

    before:
    ------
    if [ ! $? = 0 ]; then
    echo "\n\mERROR! ERROR! ERROR!\n\nWe can not establish an http ...
    update widgets. Please check yor network an proxy setting \n ...
    read -p " " network_detect;
    exit
    fi

    after:
    -----
    #if [ ! $? = 0 ]; then
    # echo "\n\mERROR! ERROR! ERROR!\n\nWe can not establish an http ...
    #update widgets. Please check yor network an proxy setting \n ...
    # read -p " " network_detect;
    # exit
    #fi

    press CTRL + 0 to save changes
    RETURN to confirm file name
    press CTRL + X to exit
    Type EXIT to close Terminal window
    ==============================================

    I use Ubuntu 8.04 virtualized over Windows XP with Microsoft Virtual PC.

    Raul (spain)
    --------


    Thanks a lot, Raul. :DRamon (Spain)
    0
  • Worked for me too, i have a localized wget since i'm from italy and had to comment that if to make the simulator run
    0

Recent Posts

in Getting Started / Beginners - Yahoo! TV Widgets