Unable to start with the Widget

The following are the steps which were taken to test the WDK at development machine:

Installation Done, Konfabulator working fine. Profile created and already created widgets checked, they were working fine.
Went to installation directory of Konfabulator i.e. usr/local/Konfabulator/TV/Widgets, and copied FinanceTV.widget.
Pasted the widget to /devwidgets folder, changed the widget’s folder name to <CompanyName>.widget.
Changed the widget.xml file inside, following changes were made:
Identifier was changed to com.<CompanyName>.tv.widgets (this domain doesn’t exist).
Name was changed to “Download Movies –<CompanyName>.
Author, organization, href, copyright, description changed accordingly.
Opened Simulator 540, but could not find any snippet in the dock (assuming that there would be two snippets with Yahoo Finance Logo, one for Actual Yahoo Finance widget and other for <CompanyName>.widget folder placed in devwidgets). Also restarted the server and then tried once again, but could not get it.

What needs to be done to ensure that widget is picked up from /devwidgets folder when the Simulator/Konfabulator loads? In case am doing something wrong, please let me know, I will change it.

Ashish Jain

3 Replies
  • You must reset the simulator to pick up and new widgets in the folder.

    Use the 540 Simulator reset tool and then reload the 540 simulator and your widget will be loaded. This must be done every time you want to test/load a new widget.
  • One point I want to add to Brian's, this is only needed when added a new widget to /devwidgets, but is a required step each time you add one.
  • Thanks a lot for the help. It worked :)Ashish Jain

Recent Posts

in General - Yahoo! TV Widgets