0

Installing on 64-bit Ubuntu?

I've got 64-bit Ubuntu 10.10 and I'm having trouble getting the emulator to work.

The first problem I ran into is that the package is an i386 package, but the 64-bit version of the OS is amd64. I was able to get around that by forcing the architecture with dpkg. After resolving the requirement for the expect package, the install worked fine.

Launching the emulator, though, there's an issue with libreadline.so.5. I have a copy, it's in /lib, but the emulator doesn't pick up on it. I symlinked the file in my TVWidgets/Konfabulator-Latest-540 directory, and the emulator picked up on the file, but then complained about how it was 64-bit.

64-bit Ubuntu isn't that recent, so there's got to be a decent number of devs out there with a 64-bit version of Ubuntu installed. I'll keep fighting the good fight to get this to work, but I'm hoping someone's already figured out the magic incantation and can let me know how (or if there's some secret version of the install that was compiled for 64-bit, where is it?)...

...Paul

by
6 Replies
  • 64-bit is not supported
    0
  • QUOTE (Benjamin Toll @ Feb 24 2011, 12:47 PM) <{POST_SNAPBACK}>
    64-bit is not supported


    Is there any plan to support it in the future?

    ...Paul
    0
  • QUOTE (...Paul @ Feb 24 2011, 01:51 PM) <{POST_SNAPBACK}>
    Is there any plan to support it in the future?

    ...Paul

    Not currently
    0
  • Paul,
    Good job figuring that out! We don't currently have official support for 64 bit OS's. While it seems you got it working, there may be unknown issues that you may run into. For this reason, we recommend working on a 32 bit platform (native or VM) before submitting a widget.
    Happy Developing!
    Jim
    0
  • I've made progress.

    From the Ubuntu forums, I found out about a great little app called "getlibs":
    http://ubuntuforums.org/showthread.php?t=474790

    I followed the directions to install it, then ran:

    getlibs -l libreadline.so.5

    It installed the 32-bit version of libreadline for me, and then I was able to launch the emulator (or at least, to the point where it says "WE NEED TO LAUNCH com.yahoo.widgets.tv.container AND IT IS NOT INSTALLED")

    ...Paul


    Download getlibs-all from
    http://frozenfox.freehostia.com/cappy/
    0
  • ...and once I blew away my TVWidgets directory and had the now-working emulator refetch everything it needed, it seems to work fine.

    ...Paul
    0

Recent Posts

in General - Yahoo! TV Widgets