Installing WDK on Ubuntu 8.10

I had some problems installing the WDK into a clean install of Ubuntu 8.10 and wanted to share the solution.

I'm not sure if the WDK works with Ubuntu 10.10, but my VM software (Parallels 5) doesn't work well with it, so I decided to install 8.10 since it is documented as supported by the WDK and Parallels 5 works with it.

The problem I ran into was that when I double clicked the ywe-wdk_1.0.0.0_i386.deb file, it complained that a dependency on libsdl-image1.2 could not be fulfilled. The error I get is "Error: Dependancy is not satisfiable: libsdl-image1.2".

It ends up that older versions of Ubuntu are moved from http://us.archive.ubuntu.com/ubuntu but the apt-get command that the Synaptic Package Manager uses still looks there.

You can update the file /etc/apt/sources.list and change all occurrences of "us.archive" to "old-release". After that, the installation will work.

0 Replies

Recent Posts

in General - Yahoo! TV Widgets