0

YAPProxy/initializeComponent() error #1009

Hi everyone!
A newbie question :
I 've coded a SWF which works well. Then, I 've created a new application via Yahoo interface and put the URL that points to the php file I want to call in the "Application URL" field.
This PHP file is like the one in examples section - that is to say :

<?php
$flashvars = http_build_query($_POST);
$yml = <<<YML
<yml:swf src="http://url.to.my.swf" width="170" height="340" flashvars="$flashvars"/>
YML;
echo $yml;
?>


then I click on "preview" and I have this AS3 error:


TypeError: Error #1009: Cannot access a property or method of a null object
at YAPProxy/initializeComponent()
at YAPProxy()



I can't find any clue about this, even by yahooing or googling it . Maybe I'm doing wrong somewhere but I'm stuck here.
Any help woul be greatly appreciated!

thanks

by
2 Replies
  • I get this same error everytime I load my swf app in the Yahoo Application Full Canvas Preview.

    In fact I get it twice because also for some reason my SWF file main object is being instantiated twice.

    Not sure what this is all about, would love to get some help.


    QUOTE (Olori @ Apr 14 2009, 04:58 AM) <{POST_SNAPBACK}>
    Hi everyone!
    A newbie question :
    I 've coded a SWF which works well. Then, I 've created a new application via Yahoo interface and put the URL that points to the php file I want to call in the "Application URL" field.
    This PHP file is like the one in examples section - that is to say :

    <?php
    $flashvars = http_build_query($_POST);
    $yml = <<<YML
    <yml:swf src="http://url.to.my.swf" width="170" height="340" flashvars="$flashvars"/>
    YML;
    echo $yml;
    ?>


    then I click on "preview" and I have this AS3 error:


    TypeError: Error #1009: Cannot access a property or method of a null object
    at YAPProxy/initializeComponent()
    at YAPProxy()



    I can't find any clue about this, even by yahooing or googling it . Maybe I'm doing wrong somewhere but I'm stuck here.
    Any help woul be greatly appreciated!

    thanks
    0
  • Hi Olori,

    This issue is being looked into (it appears to be a bug on our side). Would you be able to provide an example of the flashvars that you are setting please?

    Thanks,
    Jonathan LeBlanc

    QUOTE (Olori @ Apr 14 2009, 04:58 AM) <{POST_SNAPBACK}>
    Hi everyone!
    A newbie question :
    I 've coded a SWF which works well. Then, I 've created a new application via Yahoo interface and put the URL that points to the php file I want to call in the "Application URL" field.
    This PHP file is like the one in examples section - that is to say :

    <?php
    $flashvars = http_build_query($_POST);
    $yml = <<<YML
    <yml:swf src="http://url.to.my.swf" width="170" height="340" flashvars="$flashvars"/>
    YML;
    echo $yml;
    ?>


    then I click on "preview" and I have this AS3 error:


    TypeError: Error #1009: Cannot access a property or method of a null object
    at YAPProxy/initializeComponent()
    at YAPProxy()



    I can't find any clue about this, even by yahooing or googling it . Maybe I'm doing wrong somewhere but I'm stuck here.
    Any help woul be greatly appreciated!

    thanks
    0
  • hi!
    Thanks for answering...
    anyway, even when I don't add any flashvars the error appears ...
    One other thing : we tried to launch the same app from another machine & it was going well ( same OS as me , that is to say MACOSX). then we relaunched it from mine and the same message appeared. Maybe that will help U find out the solution ...

    best regards

    QUOTE (Jon @ Apr 15 2009, 12:57 PM) <{POST_SNAPBACK}>
    Hi Olori,

    This issue is being looked into (it appears to be a bug on our side). Would you be able to provide an example of the flashvars that you are setting please?

    Thanks,
    Jonathan LeBlanc
    0

Recent Posts

in General Discussion at YDN