0

Slow rendering of DataTable connected with server pagination

Hello.

I'm using few components : Tabs, DataTable, Context Menu together, since I decided to do "server pagination" i have issue.

http://terazpraca.home.pl/PL24/sample.php

Please navigate between subpages ( use paginator ) and see what is going on. When I look up request I see that within 2 sec I have returend data.

Here is the firebug output:

setHeader() 190 0.41% 5.52ms 1042.165ms 5.485ms 0.018ms 1036.755ms connection-min.js (wiersz 8)
setHeader() 1 0.01% 0.116ms 1036.578ms 1036.578ms 1036.578ms 1036.578ms connection-min.js (wiersz 8)
DataSource() 1 0.01% 0.073ms 1027.221ms 1027.221ms 1027.221ms 1027.221ms datasource-min.js (wiersz 11)
oFullResponse() 1 0.02% 0.243ms 1027.148ms 1027.148ms 1027.148ms 1027.148ms datasource-min.js (wiersz 8)
walk() 1 5.92% 79.082ms 448.504ms 448.504ms 448.504ms 448.504ms json-min.js (wiersz 8)
oFullResponse() 1 0% 0.03ms 334.608ms 334.608ms 334.608ms 334.608ms datasource-min.js (wiersz 8)
method() 1 0.01% 0.108ms 334.569ms 334.569ms 334.569ms 334.569ms

I really have no idea why it's happening. I'm 100% sure it's not datasource, which is checked.

Thanks.

by
0 Replies
  • Hi Rafal,

    I'm assuming that you are referring to the YUI components? You may want to post the issue to the JavaScript support group as they may be able to remedy some of the issues that you are running into: http://tech.groups.yahoo.com/group/ydn-javascript/

    - Jon

    QUOTE (Rafal W @ Jun 18 2009, 05:09 PM) <{POST_SNAPBACK}>
    Hello.

    I'm using few components : Tabs, DataTable, Context Menu together, since I decided to do "server pagination" i have issue.

    http://terazpraca.home.pl/PL24/sample.php

    Please navigate between subpages ( use paginator ) and see what is going on. When I look up request I see that within 2 sec I have returend data.

    Here is the firebug output:

    setHeader() 190 0.41% 5.52ms 1042.165ms 5.485ms 0.018ms 1036.755ms connection-min.js (wiersz 8)
    setHeader() 1 0.01% 0.116ms 1036.578ms 1036.578ms 1036.578ms 1036.578ms connection-min.js (wiersz 8)
    DataSource() 1 0.01% 0.073ms 1027.221ms 1027.221ms 1027.221ms 1027.221ms datasource-min.js (wiersz 11)
    oFullResponse() 1 0.02% 0.243ms 1027.148ms 1027.148ms 1027.148ms 1027.148ms datasource-min.js (wiersz 8)
    walk() 1 5.92% 79.082ms 448.504ms 448.504ms 448.504ms 448.504ms json-min.js (wiersz 8)
    oFullResponse() 1 0% 0.03ms 334.608ms 334.608ms 334.608ms 334.608ms datasource-min.js (wiersz 8)
    method() 1 0.01% 0.108ms 334.569ms 334.569ms 334.569ms 334.569ms

    I really have no idea why it's happening. I'm 100% sure it's not datasource, which is checked.

    Thanks.
    0

Recent Posts

in General Discussion at YDN