0

API key registration failures

It seems the domain verification step is failing when I try to register for a API key to use the Contact API.

The empty file for verification exists here:
http://hotlunchonline.net/SKzqDNpALjp.rw09BPY3Gw--.html

Any insight to why this is failing would be greatly appreciated!

Thanks,
Eric

by
28 Replies
  • Hi Chris,

    Can you please provide the app url, domain url and the title / description of the application that you are trying to register please? Alternately, a screenshot of that registration page which shows those details would help as well.

    Thanks.

    Jonathan LeBlanc
    Technology Evangelist
    Yahoo! Developer Network
    Twitter: jcleblanc
    0
  • Dear Jonathan LeBlanc,
    i have the same problem for Yahoo ! Contacts API...

    Domain Verification Failed
    We had trouble fetching the file from your server. Please make sure it's accessible. You might want to monitor your access logs to make sure our request is making it there.

    Step 1: Create an Empty Verification File

    File Name:

    kEeEQd47I3968AojMG7dZA--.html

    Step 2: Upload Verification File

    Server to Verify:

    ciramudya.byethost32.com

    Url to check:

    http://ciramudya.byethost32.com/kEeEQd47I3...ojMG7dZA--.html

    Place the file you created in step 1 at the document root of this server.


    I have made the empty file and put it at the root of this server, i also change the chmod value to 777 , how can i handle this problem?
    0
  • Dear Jonathan LeBlanc,
    i have the same problem for Yahoo ! Contacts API...

    Domain Verification Failed

    We had trouble fetching the file from your server. Please make sure it's accessible. You might want to monitor your access logs to make sure our request is making it there.
    We need to verify your domain

    To verify that you control the domain where your application will be located, you'll need to create an empty file in the root directory of your domain.

    Step 1: Create an Empty Verification File

    File Name:

    Tme1wRR2Uh0vGYJAmzjcPA--.html

    Step 2: Upload Verification File

    Server to Verify:

    test.minik.tw

    Url to check:

    http://test.minik.tw/Tme1wRR2Uh0vGYJAmzjcPA--.html

    Place the file you created in step 1 at the document root of this server.
    0
  • Dear Jonathan LeBlanc

    Here is my

    Application URL: http://www.minik.tw/index.html
    Favicon URL: http://www.minik.tw/favicon.jpg
    Description: It is a test.
    Application Domain: http://www.minik.tw
    Access Scopes: Yahoo! Contacts

    I try to verify domain, but it show the message as following:

    Domain Verification Failed

    We had trouble fetching the file from your server. Please make sure it's accessible. You might want to monitor your access logs to make sure our request is making it there.


    I am sure the verification file (http://www.minik.tw/15.fIr9FIAK0V6V.ZTdu2w--.html) is correct.

    Please let me know what the problem is?

    nick
    0
  • Hi nick,

    I think the issue that you are experiencing has to do with your favicon URL. The dashboard system validates that the URL is correct and if the picture does not exist it will throw that generic error message. Since your favicon link is broken, this could be the issue. Try removing the favicon link all together and then try verifying again please.

    - Jon
    0
  • Dear Jonathan LeBlanc
    I try to remove the favicon link, but it does'nt work. Here is the error message

    Domain Verification Failed

    We had trouble fetching the file from your server. Please make sure it's accessible. You might want to monitor your access logs to make sure our request is making it there.


    QUOTE (Jonathan LeBlanc @ Jan 15 2010, 07:03 AM) <{POST_SNAPBACK}>
    Hi nick,

    I think the issue that you are experiencing has to do with your favicon URL. The dashboard system validates that the URL is correct and if the picture does not exist it will throw that generic error message. Since your favicon link is broken, this could be the issue. Try removing the favicon link all together and then try verifying again please.

    - Jon
    0
  • Hi nick,

    I just tried loading up the files for both the application URL you provided and the verification file and neither loaded. When loading up your root domain http://www.minik.tw I receive an "unable to connect" message. That is most likely the cause of the problem if it cannot verify.

    - Jon
    0
  • QUOTE (Jonathan LeBlanc @ Jan 19 2010, 07:32 AM) <{POST_SNAPBACK}>
    Hi nick,

    I just tried loading up the files for both the application URL you provided and the verification file and neither loaded. When loading up your root domain http://www.minik.tw I receive an "unable to connect" message. That is most likely the cause of the problem if it cannot verify.

    - Jon


    QUOTE (Jonathan LeBlanc @ Jan 19 2010, 07:32 AM) <{POST_SNAPBACK}>
    Hi nick,

    I just tried loading up the files for both the application URL you provided and the verification file and neither loaded. When loading up your root domain http://www.minik.tw I receive an "unable to connect" message. That is most likely the cause of the problem if it cannot verify.

    - Jon


    Hi Jonathan LeBlanc,

    The problem might be DNS server. Here is our DNS server IP address 168.95.1.1. Could you try to set network connection to the DNS server 168.95.1.1 and try to visit our web site again.

    And could you give me your DNS server IP address you set ,if possible.
    0
  • Nick, unfortunately I cannot set or provide that information.

    - Jon
    0
  • QUOTE (Jonathan LeBlanc @ Feb 5 2010, 08:32 AM) <{POST_SNAPBACK}>
    Nick, unfortunately I cannot set or provide that information.

    - Jon


    Hi Jonathan LeBlanc

    We need to find out what the problem is.

    To find which your dns server can't analysis our domain www.minik.tw.

    For this reason we need to know your DNS server IP address, plz.

    nick
    0
  • QUOTE (Jonathan LeBlanc @ Jan 19 2010, 07:32 AM) <{POST_SNAPBACK}>
    Hi nick,

    I just tried loading up the files for both the application URL you provided and the verification file and neither loaded. When loading up your root domain http://www.minik.tw I receive an "unable to connect" message. That is most likely the cause of the problem if it cannot verify.

    - Jon


    Drear Jonathan LeBlanc

    I check my server's connection, but could'nt find any problem.

    Could u help me to find out the problem again plz.

    nick
    0
  • Hi 愛虎老游,

    Can you please provide the app url, domain url and the title / description of the application that you are trying to register please? Alternately, a screenshot of that registration page which shows those details would help as well.

    - Jon
    0
  • QUOTE (Chris @ Sep 11 2009, 09:16 AM) <{POST_SNAPBACK}>
    It seems the domain verification step is failing when I try to register for a API key to use the Contact API.

    The empty file for verification exists here:
    http://hotlunchonline.net/SKzqDNpALjp.rw09BPY3Gw--.html

    Any insight to why this is failing would be greatly appreciated!

    Thanks,
    Eric

    May be you filled the mandatory information wrong.
    Try again, it is very easy process.
    I registered my site http://www.ac-india.com in a single effort.
    0
  • Hello

    I also have the same problem.

    File: "ydnq3br7b.html"
    Url to Check: "http://raulconti.byethost24.com/ydnq3br7b.html"


    The file is already created.

    Which text should I insert in the file? There is no text appearing on the domain confirmation screenshot

    Thanks in advance
    0
  • Raúl and cira,

    Can you both please provide the information listed within my last message? I should be able to provide feedback from that.

    - Jon
    0
  • Hi,

    could you please have a look at http://developer.yahoo.net/forum/index.php?showtopic=2597 as well - experiencing exactly the same problem!

    Cheers
    Michael
    0
  • QUOTE (Michael @ Oct 6 2009, 04:55 AM) <{POST_SNAPBACK}>
    Hi,

    could you please have a look at http://developer.yahoo.net/forum/index.php?showtopic=2597 as well - experiencing exactly the same problem!

    Cheers
    Michael



    Hello

    i have the same problem,too

    my domain is 347.learnbank.com.tw / 347.com.tw / www.347.com.tw.
    they are all Domain Verification Failed

    could you help me??
    0
  • You must use the root, no subdomains.

    Robyn Tippins
    Community Manager, YDN
    0
  • I have same problem too.

    API key registration information are following:

    Application Name: Testing Wretch API
    Kind of Application: Web-based
    Description: Just for testing
    Application URL: http://shihhung.byethost7.com/apps/index.php
    Application Domain: http://shihhung.byethost7.com


    Empty Verification File are following:

    File Name: ZzA.ZjVaZCIMk0qoXV.emg--.html


    And also, I've created Verification File at

    http://shihhung.byethost7.com/ZzA.ZjVaZCIMk0qoXV.emg--.html
    0
  • i'm facing this problem too on the domain
    http://local.activedd.com/
    is't it working on sub domain ?
    the file is on:
    http://local.activedd.com/VEp8kTp7TTsNwJuqGFRDMg--.html
    0
  • Hello,

    I have many problem with your registration (Domain Verification Failed).

    And I try to manage my domain (http://www.gnak.me), from "Manage Your Domains" and it's tell
    me that's it's not a valid domain ????? Why ???

    Please, tell me what is wrong !

    Thanks.
    0
  • Having the same issues, here is my info... I also get the "Domain Verification Failed" when I say not to verify the domain name... its very frustrating

    Application Name: Flavors.me
    Kind: Web-based
    Description: Allows anyone to create an elegant website using content from around the Internet.
    Application URL: http://flavors.me
    Application Domain: http://flavors.me
    Access Scopes: This app requires access to private user data.
    TOS: Checked

    My best guess is the .me in the domain name, if so can that be fixed on Yahoo's end?
    0
  • Same problem here...CANNOT verify domain when trying to get an API key.

    Based on the fact many other people are having the same problem as I... (and this is a dead simple procedure... that incidentally
    I used successfully the very first time to verify the SAME domain under my general developer Yahoo account)
    I bet this has nothing to do with DNS.

    Can you please verify the FAVIcon is truly 'OPTIONAL? (I don't have one)
    Also, my domain is ALREADY verified (as mentioned above) through Developer.Yahoo.com, so..could THAT be the problem ?

    Web Server Access logs show:
    68.142.241.105 - - [10/Mar/2010:17:10:46 -0500] "GET /C5SyXhp6Yj_Uq7x9JB9cQA--.html?r=1101576744 HTTP/1.1" 200 12 "-" "-"

    That's gotta be a Yahoo IP, but still came back as failure. (I bet the FAVICON is actually required)..

    -Jay D.
    0
  • Continued API Key registration failure (today and last night)

    -- Confirmed - Definitely a YAHOO / non-DNS issue here:

    I just added a (temp/lousy) favicon.. and also created a subdir and index file for the app.. in the event these might make a difference.
    They didn't.

    APACHE LOG FILE from last attempt:

    68.142.241.104 - - [10/Mar/2010:17:56:21 -0500] "GET /C5SyXhp6Yj_Uq7x9JB9cQA--.html?r=1620173733 HTTP/1.1" 200 1 "-" "-"
    68.142.241.104 - - [10/Mar/2010:17:56:21 -0500] "GET /favicon.gif HTTP/1.1" 200 135 "-" "-"

    Two successful file accesses yet I still received:

    Domain Verification Failed
    There was an internal error while an application is being created. Please try again.



    Please correct this.

    Also please note that I had NO PROBLEM verifying the very same domain through Developer.Yahoo.com (when not trying to obtain an API key)

    Thanks for your help.

    Jay
    0
  • QUOTE (Wit. T. Guy @ Mar 10 2010, 03:08 PM) <{POST_SNAPBACK}>
    ....

    APACHE LOG FILE from last attempt:
    68.142.241.104 - - [10/Mar/2010:17:56:21 -0500] "GET /C5SyXhp6Yj_Uq7x9JB9cQA--.html?r=1620173733 HTTP/1.1" 200 1 "-" "-"
    68.142.241.104 - - [10/Mar/2010:17:56:21 -0500] "GET /favicon.gif HTTP/1.1" 200 135 "-" "-"

    Two successful file accesses yet I still received:

    Domain Verification Failed
    There was an internal error while an application is being created. Please try again.



    Please correct this.

    Also please note that I had NO PROBLEM verifying the very same domain through Developer.Yahoo.com (when not trying to obtain an API key)

    Thanks for your help.

    Jay



    -Sorry for the multiple posts. I (had) previously added some text to the file..which is why it showed 1 byte size previously.

    I corrected this..made it a zero byte file..and logs show 200 success again..while I continue to receive the SAME 'Internal error' on your Yahoo Web Api results page.

    68.142.241.104 - - [10/Mar/2010:18:10:56 -0500] "GET /C5SyXhp6Yj_Uq7x9JB9cQA--.html?r=1219696081 HTTP/1.1" 200 - "-" "-"
    68.142.241.104 - - [10/Mar/2010:18:10:56 -0500] "GET /favicon.gif HTTP/1.1" 200 135 "-" "-"



    If you need my domain, I'll be glad to provide it,. (but then, of course, I'll have to delete the temp html ownership file)

    Thanks for looking into this!
    0
  • -----------------------------------------------------
    I deleted the ownership .html file -

    (again. TRYING to verify (an already verified) domain during the process required to get an API key ..but receive Internal Error during Domain Verification)

    My APP INFO:

    Application Name: Merely Hilarity
    Kind: Web-based
    Description: Something related to humor, blah blah.....................
    Application URL: http://wittyguy.com/yap/index.php
    Application Domain: http://wittyguy.com
    Access Scopes: This app requires access to private user data.
    TOS: Checked
    0
  • We are also experiencing errors in verifying our valid domain name.

    We are trying to verify the domain:
    http://7-eleven.com.ph

    It seems that the system is rejecting domains that start with numbers as we are also unable to verify
    http://98labs.com

    Immediate help would be appreciated.

    To reproduce, go to MY PROJECTS(https://developer.apps.yahoo.com/devtool/projects)
    On the right most part, click on Manage Domains then click on Add Domain and type in:
    7-eleven.com.ph

    or

    98labs.com

    We always get a "Please provide a valid domain." error
    0
  • Hi bluemage,

    We've forwarded this post internally to take a look into the issue. Please stay tuned.

    - Jon
    0
  • Hi, I am trying to verify a domain http://beta.qizma.com/SKb5AuxXYyqW8Q99vqsBSg--.html<br><br>I made sure that the file is uploaded. Still no luck though :(<br><br><div class="quote"><div class="quotetop">QUOTE<cite>(Jonathan LeBlanc @ 12 Jul 2010 8:52 AM)</cite></div><blockquote class="quotemain">Hi bluemage,<br><br>We&#39;ve forwarded this post internally to take a look into the issue. Please stay tuned.<br><br>- Jon</blockquote></div>
    0
  • <span style="color:#333333;line-height:16px;text-align:left;">i have also experiencing errors in verifying our valid domain name.&nbsp;</span><a href="http://www.ukash-tr.com/">ukash</a><br><span style="color:#333333;line-height:16px;text-align:left;">We are trying to verify the domain:</span><br><p><a href="http://www.ukash-tr.com/">http://www.ukash-tr.com</a></p><br><span style="color:#333333;line-height:16px;text-align:left;">system is rejecting domains that start with numbers as we are also unable to verify</span><br><p><a href="http://www.ukash-tr.com/">http://www.ukash-tr.com</a></p>
    0
  • <span style="color:#333333;line-height:16px;text-align:left;">i have also experiencing errors in verifying our valid domain name.&nbsp;</span><a href="http://www.ukash-tr.com/">ukash</a><br><span style="color:#333333;line-height:16px;text-align:left;">We are trying to verify the domain:</span><br><p><a href="http://www.ukash-tr.com/">http://www.ukash-tr.com</a></p><br><span style="color:#333333;line-height:16px;text-align:left;">system is rejecting domains that start with numbers as we are also unable to verify</span><br><p><a href="http://www.ukash-tr.com/">http://www.ukash-tr.com</a></p>
    0
  • <br>Are you joking!&nbsp; Here we are two years later and this crap still isn&#39;t fixed.&nbsp; BFM!&nbsp; What a joke.&nbsp; I don&#39;t have time for this crap.&nbsp;What is the conspiracy behind this verification file/process not working?&nbsp; Someone surely must have an answer.&nbsp; <br><br>Learning Wordpress,<br>http://www.hightechblizzard.com<br>Tim
    0
  • i have a same problem yoo the problem is not fix it in wordprees site one of my web site is ukash file is not working i think someone find this solution if share us we are so glad to find and my site http://www.ukashturkiye.com.tr
    0
  • Nice share... Look what hottest and shocker news in Indonesia on Iklan Internet Murah Efektif Berkualitas Indonesia
    0
  • i provided full details on https://developer.apps.yahoo.com/dashboard/createKey.html?oauth_submit=Get+API+Key

    but unable to create project to get api key for my importing contacts

    0

Recent Posts

in General Discussion at YDN