1

APT V10 AccountPlacementPerformance Report Days Are Off

Since Saturday 2/25, the stats returned by a saved daily AccountPlacementPerformance do not contain the dates that were requested.

Here is the SOAP payload that I am sending to create the report (some content omitted):

<?xml version='1.0' encoding='UTF-8'?>
<soapenv:Envelope ...>
<soapenv:Header>
<ns2:Security ...>
<UsernameToken>
<Username>********
</Username>
<Password>********
</Password>
</UsernameToken>
</ns2:Security>
<ns1:license ...>********
</ns1:license>
<ns1:accountID ...>********
</ns1:accountID>
</soapenv:Header>
<soapenv:Body>
<ns1:addSavedReportRequest ...>
<ns1:reportRequest>
<ns1:contextID>0
</ns1:contextID>
<ns1:dataGrouping>Day
</ns1:dataGrouping>
<ns1:endDate>2012-02-27T13:54:57.573-05:00
</ns1:endDate>
<ns1:reportName>AccountPlacementPerformance
</ns1:reportName>
<ns1:startDate>2012-02-26T13:54:57.573-05:00
</ns1:startDate>
</ns1:reportRequest>
</ns1:addSavedReportRequest>
</soapenv:Body>
</soapenv:Envelope>

After the report is ready, it looks like this (some content omitted):

<?xml version="1.0" encoding="UTF-8"?>
<report name="AccountPlacementPerformance" dateStart="2012-02-25-0500" dateEnd="2012-02-26-0500" ...>
<sort ... />
<filter columnName="acctID" operator="EQUALS" value="********" /><totals><analytics .../></totals>
<row flatPlmtID="********" ... date="2012-02-25 - 2012-02-25"><analytics .../></row>
<row flatPlmtID="********" ... date="2012-02-26 - 2012-02-26"><analytics .../></row>
</report>

As you can see, I am requesting 2/26-2/27 and an getting 2/25-2/26 in the report.

Has anyone else seen this issue? Is this being addressed?

by
3 Replies
  • ok, xml certainly doesn't work...

     
    &lt;?xml version=&#39;1.0&#39; encoding=&#39;UTF-8&#39;?&gt;&lt;soapenv:Envelope xmlns:soapenv=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot;&gt;&lt;soapenv:Header&gt;&lt;ns2:Security xmlns:ns2=&quot;http://schemas.xmlsoap.org/ws/2002/07/secext&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;&lt;UsernameToken&gt;&lt;Username&gt;********&lt;/Username&gt;&lt;Password&gt;********&lt;/Password&gt;&lt;/UsernameToken&gt;&lt;/ns2:Security&gt;&lt;ns1:license xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;********&lt;/ns1:license&gt;&lt;ns1:accountID xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;********&lt;/ns1:accountID&gt;&lt;/soapenv:Header&gt;&lt;soapenv:Body&gt;&lt;ns1:addSavedReportRequest xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot;&gt;&lt;ns1:reportRequest&gt;&lt;ns1:contextID&gt;0&lt;/ns1:contextID&gt;&lt;ns1:dataGrouping&gt;Day&lt;/ns1:dataGrouping&gt;&lt;ns1:endDate&gt;2012-02-27T13:54:57.573-05:00&lt;/ns1:endDate&gt;&lt;ns1:reportName&gt;AccountPlacementPerformance&lt;/ns1:reportName&gt;&lt;ns1:startDate&gt;2012-02-26T13:54:57.573-05:00&lt;/ns1:startDate&gt;&lt;/ns1:reportRequest&gt;&lt;/ns1:addSavedReportRequest&gt;&lt;/soapenv:Body&gt;&lt;/soapenv:Envelope&gt;</code>
    0
  • XML needed tags...

    code sample 1:
     
    &lt;?xml version=&#39;1.0&#39; encoding=&#39;UTF-8&#39;?&gt;&lt;soapenv:Envelope xmlns:soapenv=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot;&gt;&lt;soapenv:Header&gt;&lt;ns2:Security xmlns:ns2=&quot;http://schemas.xmlsoap.org/ws/2002/07/secext&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;&lt;UsernameToken&gt;&lt;Username&gt;********&lt;/Username&gt;&lt;Password&gt;********&lt;/Password&gt;&lt;/UsernameToken&gt;&lt;/ns2:Security&gt;&lt;ns1:license xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;********&lt;/ns1:license&gt;&lt;ns1:accountID xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot; soapenv:mustUnderstand=&quot;0&quot;&gt;********&lt;/ns1:accountID&gt;&lt;/soapenv:Header&gt;&lt;soapenv:Body&gt;&lt;ns1:addSavedReportRequest xmlns:ns1=&quot;http://apt.yahooapis.com/V10&quot;&gt;&lt;ns1:reportRequest&gt;&lt;ns1:contextID&gt;0&lt;/ns1:contextID&gt;&lt;ns1:dataGrouping&gt;Day&lt;/ns1:dataGrouping&gt;&lt;ns1:endDate&gt;2012-02-27T13:54:57.573-05:00&lt;/ns1:endDate&gt;&lt;ns1:reportName&gt;AccountPlacementPerformance&lt;/ns1:reportName&gt;&lt;ns1:startDate&gt;2012-02-26T13:54:57.573-05:00&lt;/ns1:startDate&gt;&lt;/ns1:reportRequest&gt;&lt;/ns1:addSavedReportRequest&gt;&lt;/soapenv:Body&gt;&lt;/soapenv:Envelope&gt;




    code sample 2 (some omitted for post limit):

     
    <?xml version="1.0" encoding="UTF-8"?><report name="AccountPlacementPerformance" dateStart="2012-02-25-0500" dateEnd="2012-02-26-0500" ...><sort ... /><filter columnName="acctID" operator="EQUALS" value="********" /><totals><analytics .../></totals><row flatPlmtID="********" ... date="2012-02-25 - 2012-02-25"><analytics .../></row><row flatPlmtID="********" adGrpPlmtName="********" plcmntStatus="Active" buyingType="Guaranteed" netAcctName="Yahoo! Ad Network" txnmyName="All" cstmTxnmyName="All" siteName="All" targetTxt="********" plcmntAdSize="300x250" lineStartDate="2011-12-01 00:00:00 EST" lineEndDate="2012-06-30 23:59:59 EDT" dlvryMdl="Impression Based" pricingType="CPM" rateBookedMeCrncy="8" crtvOptEnbld="False" crncyCode="USD" date="2012-02-26 - 2012-02-26"><analytics imprDlvrd="2,930" clickDlvrd="1" ctr="0.03" conv="0" effectiveRateMeCrncy="8.00" costDlvrdMeCrncy="23.44" cpm="8.00" cpc="23.44" relImprShare="53.23" relClickShare="25.00"/></row></report>
    0
  • I cant get my code in here properly because sometimes a new reply edits my old reply and sometimes it is deleted.
    0
  • What a mess of a post. The question still stands. Substitute in the code samples to the main question and all will make sense.
    0
This forum is locked.

Recent Posts

in General - APT