0

The table fantasysports.draftresults requires a higher security level than is provided, you provided ANY but at least USER is expected

HELLO All,

{"error":{"lang":"en-US","diagnostics":null,"description":"Authentication Error. The table fantasysports.draftresults requires a higher security level than is provided, you provided ANY but at least USER is expected"}}

In YQL console my query is working fine. but when I send request from my app or I hit the url on browser its showing me above error. Has anyone solved this error before, if yes please tell what process should i follow?

by
9 Replies
  • getData({"error":{"lang":"en-US","diagnostics":null,"description":"Authentication Error. The table fantasysports.leagues requires a higher security level than is provided, you provided ANY but at least USER is expected"}});

    having same issue.... do any one know how to send yql request from ios and what extra parameter need to be send... ?

    0
  • Did you ever find a solution to this? I am trying to write something and getting the same error. Thanks.

    0
  • It sounds like you have not completed the oAuth steps are trying to connect directly?

    Here's Yahoo's guide on oAuth: https://developer.yahoo.com/oauth/

    If this is not the case and you've already completed these steps, let me know.

    Also, when posting it is useful if you can post your URI parameters or what you're actually doing in addition to the results.

    0
  • The whole process just seems way too complicated to me. What I'm trying to do is very simple but I can't even get results using the YQL console. I just want to execute a YQL query to list the rosters of fantasy football teams in my league from last year. I did something similar last year but for some reason can't get any data returned now.

    0
  • Just running a simple query like: select * from fantasysports.games where game_key='nfl';

    Does not return data: { "query": { "count": 0, "created": "2014-05-09T19:03:40Z", "lang": "en-US", "diagnostics": { "publiclyCallable": "true", "url": { "execution-start-time": "0", "execution-stop-time": "21", "execution-time": "21", "http-status-code": "500", "http-status-message": "INKApi Error", "content": "http://fantasysports.yahooapis.com/fantasy/v2/games;game_keys=nfl" }, "user-time": "21", "service-time": "21", "build-version": "0.2.2467" }, "results": null } }

    0
  • OK. I was able to get through the oauth process. Even after doing so, my page that tries to access the actual data gets the following:

    {"error":{"lang":"en-US","diagnostics":null,"description":"Authentication Error. The table fantasysports.games requires a higher security level than is provided, you provided ANY but at least USER is expected"}}

    The Yahoo authorization page comes up and acknowledges that the application is trying to access Fantasy Sports data but I still get the error.

    0
  • Chris, I'm having the same issue with accessing the Fantasy Sports API via the YQL console. Haven't found anyone who can explain what is going on, but enough people have chimed in that it seems safe to conclude that the Fantasy Sports API is nonfunctional via the console.

    0
  • I have the same problem

    0
  • Ever any luck here?

    0

Recent Posts

in Fantasy Sports API