No results

We've been trying to test the Content Analysis service but are finding in many case we gets "results": null' as the response. In some cases, attempting the same query a few minutes later we'll actually get data about the submitted URL, but in the bulk of (admittedly a small sample of ~ 20 domains) we will keep getting "results":null.

Is the service actually working or is there some limitation in queries tested using the YQL Console?

If this is not a limitation;
  1. is there a reason for null results (when the given URLs are accessible online)?
  2. is there a reason that data becomes available in a re-query?
  3. is this service 'production ready', or should it be considered 'unstable'?
EG, even running a simple query like "select * from contentanalysis.analyze where url='http://yahoo.com'" was returning "results":null (now it's returning "an error has occurred".


4 Replies
  • Any news on this?

    Will this get fixed anytime soon?

  • I am seeing a lot of this too. The status monitor shows normal at the moment and all api requests are returning results null. Was doing this yesterday too but was working ok this morning.

    Any info on this would be appreciated as this is an awesome API when its working!! :)



  • Please advise on current limitations and confirm if we should be receiving a particular error. I seem to be able to make about 300 API calls ok and then I just get <results:null.> I have tried sleeping for 4 seconds before each call and the outcome is still the same.

  • I am having this issue also. Is there some kind of undocumented cap here?

    I am doing it from public ip addresses not even coming close to a limit thats documented.

    No luck.. such a cool service seems so handy capped by issues like this.

    Not withstanding, would it not throw a limit overage error of some kind? Nothing for response from it.

    object(stdClass)#840 (1) { ["query"]=> object(stdClass)#841 (4) { ["count"]=> int(0) ["created"]=> string(20) "2013-08-20T22:43:10Z" ["lang"]=> string(5) "en-US" ["results"]=> NULL } }


Recent Posts

in Content Analysis API