Empty Yahoo contact list

I`m getting empty contact list. It worked fine few days back.

://social.yahooapis.com/v1/user/THQTY2LPI4VGWOOMGFVQFINBII/contacts;count=1000 Response:{"contacts":{"contact":[],"count":0,"start":0,"total":0,"uri":"http://social.yahooapis.com/v1/user/THQTY2LPI4VGWOOMGFVQFINBII/contacts"}}

27 Replies
  • I have exaclty the same problem. Does anybody have an idea what the problem might be?

  • I use oauth to get contact list. It works fine, until few days ago. Is a yahoo problem?

  • I have just wrote the code to import contact, It works until login form but returns null for contact details. Is anybody got the solution for the same problem? Please suggest.

  • Same problem with me. object(stdClass)#8 (1) { ["query"]=> object(stdClass)#9 (4) { ["count"]=> int(0) ["created"]=> string(20) "2014-06-26T10:11:40Z" ["lang"]=> string(5) "en-US" ["results"]=> NULL } } yeterday it worked for me but today it not working ,,, Please Suggest .

  • I got the same Problem.


  • I download code project:

    http://www.codeproject.com/Articles/91646/Implementing-Yahoo-Contact-Reader-Using-ASP-NET (Implementing Yahoo! Contact Reader Using ASP.NET)

    But, this project cannot get email (error 404)

    Uri uri = new Uri("http://social.yahooapis.com/v1/user/" + OauthYahooGuid + "/contacts?format=XML");


    string authHeader = "Authorization: OAuth " + "realm=\"yahooapis.com\"" + ",oauth_consumer_key=\"" + ConsumerKey + "\"" + ",oauth_nonce=\"" + nonce + "\"" + ",oauth_signature_method=\"HMAC-SHA1\"" + ",oauth_timestamp=\"" + timeStamp + "\"" + ",oauth_token=\"" + OauthToken + "\"" + ",oauth_version=\"1.0\"" + ",oauth_signature=\"" + HttpUtility.UrlEncode(sig) + "\"";

    Pls help me.


  • This happened to me too, the code was working then suddenly the contacts list always empty

  • Hello Guys,

    I was also suffered from same issue. But today I got the solution for the same. In current update yahoo allowing access to contact api only through "https". So you need to edit your "yahoo.inc" file. Replace all "http" by "https" protocol

    Note : - While replacing the "http" by "https", please make sure your site url wont get replaced. Feel free to post your status here.

    Thank You.

  • I changed http to https a long time ago. This does not seem to cause the problem in my case. I still get an empty contact list.

  • doesn't work for me ...

  • same here also, it didn't work

  • Can any one yet able to fix that issue ? Is that API error from yahoo side ?

  • Looks like the issue observed depending on client regional location. Client setup in eastern Europe returned 0 contacts. From US for all test accounts I've tried Yahoo API performed as expected (returning contacts list).

  • I am in the US and get 0 contacts.

  • Depending on Yahoo load balancing configuration for social.yahooapis.com, as expected, different servers are resolved.

    IP resolved from my machine located in Burlington, MA (

    tracert social.yahooapis.com 1 1 ms 1 ms <1 ms 2 <1 ms <1 ms <1 ms 3 4 ms 4 ms 4 ms gigabitethernet1-0-0.gw3.bos4.alter.net [] 4 11 ms 11 ms 10 ms 0.ae2.br1.nyc1.alter.net [] 5 * * * Request timed out. 6 11 ms 11 ms 11 ms vlan51.ebr1.newyork2.level3.net [] 7 11 ms 11 ms 11 ms ae-4-4.ebr1.newyork1.level3.net [] 8 12 ms 10 ms 10 ms ae-71-71.csw2.newyork1.level3.net [] 9 11 ms 12 ms 11 ms ae-2-70.edge4.newyork1.level3.net [] 10 37 ms 45 ms 31 ms yahoo-inc.edge4.newyork1.level3.net [] 11 26 ms 19 ms 21 ms ae-2.pat1.bfz.yahoo.com [] 12 20 ms 22 ms 22 ms ae-3.msr2.bf1.yahoo.com [] 13 20 ms 22 ms 23 ms xe-1-2-1.clr1-a-gdc.bf1.yahoo.com [] 14 22 ms 20 ms 22 ms et17-1.fab5-1-sat.bf1.yahoo.com [] 15 24 ms 20 ms 38 ms po-10.bas2-1-prd.bf1.yahoo.com [] 16 20 ms 19 ms 19 ms r1.ycpi.vip.bf1.yahoo.net []

    For IP address resolved from Kiev, Ukraine (

    tracert 1 <1 ms <1 ms <1 ms 2 1 ms <1 ms <1 ms 3 4 ms 4 ms 4 ms gigabitethernet1-0-0.gw3.bos4.alter.net [] 4 12 ms 10 ms 10 ms 0.ae1.br1.nyc1.alter.net [] 5 * * * Request timed out. 6 97 ms 96 ms 96 ms vlan51.ebr1.newyork2.level3.net [] 7 96 ms 96 ms 96 ms ae-46-46.ebr1.newyork1.level3.net [] 8 106 ms 97 ms 97 ms ae-44-44.ebr2.london1.level3.net [] 9 96 ms 96 ms 96 ms vlan101.ebr1.london1.level3.net [] 10 97 ms 97 ms 97 ms ae-24-24.ebr2.frankfurt1.level3.net [] 11 96 ms 98 ms 96 ms ae-92-92.csw4.frankfurt1.level3.net [] 12 96 ms 96 ms 135 ms ae-4-90.edge5.frankfurt1.level3.net [] 13 96 ms 96 ms 96 ms yahoo-inc.edge5.frankfurt1.level3.net [] 14 92 ms 92 ms 92 ms r2.ycpi.vip.dee.yahoo.net []

    I was able to reproduce this issue on my local machine using my personal account after adding Ukrainian IP address "" into Windows hosts file (C:\Windows\System32\Drivers\etc\hosts). While contacts downloaded successfully if I use regular setup (without altering hosts file).

  • So, looks like a replication failure occurred on Yahoo network.

  • Thanks a lot for this information! So, I guess we have to wait for yahoo to fix this issue, no?

  • Alexander,

    You mentioned that you observed failures while connecting from US. That is what I never seen ... yet.

    Could you specify your city and state? And where the account you are using has been registered? I mean from which geographical location client has connected to Yahoo first time (in order to create an account)?


  • Hi Oleksandr,

    you are right. Now I remember that I was in Romania, when I created this account, so this supports your theory.

    I just created another Yahoo account within the US (Chicago, IL) and exchanged the key/secret in my code. Unfortunately I still get an empty contact list...

    Any ideas?


  • Hi,

    I am trying this from belgium. I am also getting an empty contact list. Will really appreciate any solution to this problem.

    Regards -Praful

  • Same here, Israel and USA both returns an empty list.. (started a month ago)

    however, i tried to import my contacts though outlook.com service and it worked. i guess they are using different integration..

  • I tried this from India. It works. The same code doesn't work from Belgium. Any one else facing this issue.

  • Evyatar,

    I don't think so, to me it works depending on exact physical endpoint resolved by DNS for social.yahooapis.com That depends on client machine location. In case of outlook.com - looks like its server, while performing you contacts upload from Yahoo, was lucky enough to establish connection to the healthy endpoint of the Yahoo network.

    My current office is in Boston area (MA), and as per what our QA dept reports - Yahoo contacts are uploaded correctly for all the accounts they tried from this location. When using VPN tunneling to different locations in Europe - it returns 0 contacts for most of the cases. We also have a dev/QA dept in Ukraine, where guys are reporting 100% failure rate.

    Here are my ideas on what is happening: Yahoo constantly tries to fix bugs in their system, but for some reason create some new after each update to their network. Here are couple examples of what our team faced recently: - we observed the similar problem, but with OAuth in March/April. OAuth AccessToken acquired successfully from US, while in Ukraine it wasn't working at all; Issue has been fixed buy Yahoo in couple months; - approx. 1 month ago I've got a bug-report saying that contacts upload stopped working at all (returning HTTP error-code). As it was found, with recent update Yahoo introduced case-sensitivity to their API. We used to submit enumerated parameter values in Pascal casing, while as per yahoo docs these params should go lower-cased (like "format", we were requesting "... format=Json" instead of "... format=json"). It is not a Yahoo issue, since we were not 100% flowing the API guidelines. But that has been working fine for more than a year, so why do Yahoo changed that all, decreasing versatility? - and now we have again a problem which depends on client location. At least it doesn't return HTTP error code. Just 0 contacts, which probably looks less disruptive for end-user experience.

    To me it looks like every valued professional who has been working for Yahoo in previous decade just quit and went to work for Google, Apple or whatever company which develops new quality products. Yahoo just trying to keep-up with the technical debt legacy and stays floating due to that huge volume of client accounts registered before Google era (though that is also a reason why we are integrating Yahoo into our product as well). I pissed-off that Yahoo even can't keep up with timely response to our claims, at least to provide any estimate when we should expect the issue get fixed. From opposite side they provide API for free and "as is", which also the synonym to "we don't care of your problems, since we are not making money on you".

  • Got the solution

    Just replace "http" in http://social.yahooapis.com/v1/user with "https" and all ports from 80 to 443. Worked for me.

  • Oleksandr,

    you were right, changing the hosts did the trick.

    thank you!

  • Yahoo seems to have fixed the issue. It finally works again for me, although I didn't change anything in the code.

  • Still facing the same issue from NYC.


Recent Posts

in Contacts